cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
cpan
Level: Powered On

BadGateway (500 Error)

I am starting getting BadGateway 500 error when accessing a shared mailbox to "mark email as read" in Flow. The office 365 account has full access to the shared mailbox. The error shows "Cannot open mailbox.". Does anyone have similar issue this morning?

 

{
"error": {
    "code": 500,
    "source": "flow-apim-msmanaged-na-westus2-01.azure-apim.net",
    "message": "BadGateway",
    "innerError": {
      "error": {
        "code": "ErrorInternalServerError",
        "message": "An internal server error occurred. The operation failed., Cannot open mailbox.",
          "date": "2019-09-13T17:29:53"
        }
      }
    }
  }
}
1 ACCEPTED SOLUTION

Accepted Solutions
Community Support Team
Community Support Team

Re: BadGateway (500 Error)

Hi @cpan ,

 

I'm afraid that there is any issue with microsoft flow when your flow has run failed.

Could you please take a try to run the flow again to see if the issue still exists?

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

4 REPLIES 4
cpan
Level: Powered On

Re: BadGateway (500 Error)

It seems the "Mark as read", "Flag email", "Export email" are getting the same BadGateway issue. The Flows that failed today are running fine for monthes and without any permission issue.
 
{
"error": {
    "code": 502,
    "source": "flow-apim-msmanaged-na-westus2-01.azure-apim.net",
    "message": "BadGateway",
    "innerError": {
      "status": 502,
      "message": "Request failed. Try again later.",
      "source": "office365-wus.azconn-wus.p.azurewebsites.net"
    }
  }
}
MatthewW1992
Level: Power Up

Re: BadGateway (500 Error)

I have started having this issue as well over the past 24 hours

cpan
Level: Powered On

Re: BadGateway (500 Error)

If you use “mark as read”, “flag email”, or “ export email” for a “shared mailbox”, you will get the BadGateway 500/502 sooner or later. If you use the tasks for a user owned mailbox, there will be no error. Microsoft is now aware of this issue. There is no ETA when Microsoft will have these tasks for a Shared Mailbox.

The workaround is to forward the email from shared mailbox to a user own mailbox, and use flow to monitor the user own mailbox.
Community Support Team
Community Support Team

Re: BadGateway (500 Error)

Hi @cpan ,

 

I'm afraid that there is any issue with microsoft flow when your flow has run failed.

Could you please take a try to run the flow again to see if the issue still exists?

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
firstImage

Power Platform Online Conference

Speakers, submit your sessions now! Call for speakers ends Feb. 10!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors (Last 30 Days)
Users online (4,004)