cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
darrenfloyd666
Post Prodigy
Post Prodigy

Blank 'Login to Flow' screen when I try and run a flow from a Business Process Flow

I'm trying to fire a Approval Flow from a Business Process Flow in my Model Driven App:

RunFlow.png

 

But when I click 'Run Flow' I'm getting the blank screen shown below. Has anyone else had this? I haven't a clue what the issue could be? 

LogintoFlow.png

7 REPLIES 7
-Rem-
Frequent Visitor

Have you ever managed to fix this? I have exactly the same issue. Today, I was able to use Flows normally - including the signing in, but now all I get is a blank screen. 

Klemens
Regular Visitor

same issue here, I have a "app per user" licence for CRM and the power automate per user licence.

 

This is already enabled in my organisation:

https://docs.microsoft.com/en-us/power-platform/admin/enable-embedded-flow-in-your-organization

 

Under System Settings > customisation in CRM flow is also enabled. 

 

When navigating to Settings > Microsoft Flow I get a login button. clicking on this opens a new tab for split seconds and then closes it again. 

msfreaks
New Member

For anyone still facing this issue, I solved it by changing the tracking option in the settings for my browser (Edge in my case) from Strict to Balanced.

msfreaks_0-1626876090146.png

 

Refreshed the Model Driven App in the browser. This resulted in the "login to flow" option disappearing from the "Flows" menu item.

I was then able to run the business flow (after logging in to Flow) where previously I had the Blank Log in to Flow popup.

 

If your company policy requires Strict, you could add exceptions to the profile for [*.]dynamics.com (part of your environment url) and [*.]powerapps.com:

msfreaks_0-1626876855920.png

 

 

Cheers,

 

Arjan

 

Miesadlo
Frequent Visitor

hi,

 

you need to log out from power automate first. Afterwards you can execute flow 🙂

Hello Miesadlo, May I know why do I need to log out ? What could be the reason why I can execute flow afterwards ?
Can you please assist me why it is happening and how to fix that, please ? Thank you. 

Miesadlo
Frequent Visitor

Hi  YanNaing,

 

This blank screen happend to me multiple times.... I have been trying a lot but only solution that worked for me was the log-out. I have worked on different projects so maybe that is the reason why it was stucked...


Try these tips:
1. sign in to power automate and then log out (power automate somehow still remember you)
2. clear cache
3. check licenses... you need to have per user plan

YanNaing23
New Member

Thanks alot Miesadlo! Let me try with those approach and see how it goes. Appreciated that.

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

May UG Leader Call Carousel 768x460.png

June User Group Leader Call

Join us on June 28 for our monthly User Group leader call!

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Power Automate Designer Feedback_carousel.jpg

Help make Flow Design easier

Are you new to designing flows? What is your biggest struggle with Power Automate Designer? Help us make it more user friendly!

Users online (3,496)