cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
cagepeh
Frequent Visitor

CREATE HTML Table missing data in column

Dear all,

 

I have created an scheduled flow with a query on daily record. 

After which, using the filtered data, create a html table to show inside an email.

Everything can be executed just fine. But strangely, 2nd column data is not showing up in the HTML table.

The data can be seen in the Inputs window. But it is not shown in the table inside the Outputs window.

cagepeh_0-1663921576548.png

Anyone can advise what is wrong with the coding? 

 

Thanks much.

1 ACCEPTED SOLUTION

Accepted Solutions
v-yujincui-msft
Community Support
Community Support

Hi @cagepeh ,

 

UPDATE: 

Sorry, I didn't refresh the page so didn't notice that @Hardesh15 had provided the right direction.

 

Could you please provide screenshots in edit mode (No sensitive data)?

If you are using expressions then I suggest you to check that you are using the correct internal column names.

vyujincuimsft_0-1663923667690.jpeg

In addition, here is a link for your reference.

https://tomriha.com/what-is-sharepoint-column-internal-name-and-where-to-find-it/

 

 

Best Regards,

Charlie Choi

View solution in original post

3 REPLIES 3
Hardesh15
Super User
Super User

@cagepeh Check dynamic content for worker Team in your HTML table action.

Please 'Thumbs Up' the posts that helped you and 'Accept as Solution' if my post answered your question.

@Hardesh /Gopenly.in

v-yujincui-msft
Community Support
Community Support

Hi @cagepeh ,

 

UPDATE: 

Sorry, I didn't refresh the page so didn't notice that @Hardesh15 had provided the right direction.

 

Could you please provide screenshots in edit mode (No sensitive data)?

If you are using expressions then I suggest you to check that you are using the correct internal column names.

vyujincuimsft_0-1663923667690.jpeg

In addition, here is a link for your reference.

https://tomriha.com/what-is-sharepoint-column-internal-name-and-where-to-find-it/

 

 

Best Regards,

Charlie Choi

cagepeh
Frequent Visitor

Thanks for the guidance.

 

Apparently, Power Automate cannot have "/" inside the name of the field for Dynamic Content.

cagepeh_0-1664241609302.png

Using the above, the data in that field will not be shown.

After I change it to an expression, as below.

cagepeh_1-1664241736702.pngcagepeh_2-1664242219930.png

 The data finally showed up in the HTML table.

 

Thanks much. 😁

 

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Difinity Conference 2022

Difinity Conference 2022

Register today for two amazing days of learning, featuring intensive learning sessions across multiple tracks, led by engaging and dynamic experts.

European SharePoint Conference

European SharePoint Conference

The European SharePoint Conference returns live and in-person November 28-December 1 with 4 Microsoft Keynotes, 9 Tutorials, and 120 Sessions.

Users online (5,065)