cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ricardosanchezm
Advocate II
Advocate II

Can't see my flows in Microsoft Teams Flow Tab

Hi Folks,

 

I have created a set of Flows time ago which I can execute perfectly in the Flow portal. Recently I created a Flow tab in Microsoft Teams to access them quickly but when opening the tab my flows are no there.

 

These are my flows in the portal:

 

1.PNG

These is the view from Microsoft Teams Flow tab (no flows visible):2.PNG

Could you help me with this?

Regards,

14 REPLIES 14
v-alzhan-msft
Community Support
Community Support

Hi @ricardosanchezm ,

 

I have made a test and don't have the issue that you mentioned, I could see the flows in Microsoft Teams as below:

1.png

The flow tab would show some minutes after you click the Flows botton, please retry again and let me know if your issue still exists.

 

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

yashag2255
Dual Super User II
Dual Super User II

Hi @ricardosanchezm 

 

For this to work, ensure that the flow you create is in Default environment and the Flow is shared with the memebers of the entire team for which you have added the flow tab. 

 

I just tested this in my environment and it worked that way. 

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Hi @v-alzhan-msft ,

The way you are accessing the flows works fine for me too but that's not what I need. What I need is to access them trought a channel. For this I use the plus button to add tab and then select Flow. After this what I expect I to see the flows that I have created but I can't see them.

 

1.PNG

Regards,

Hi @yashag2255 ,

I have created a Team in which I am the only member for test purposes. I created a flow in my default environment which I can see perfectly in the portal. After this I added a Flow in the General channel but still can't see my flows from the Flow tab.

 

2.PNG

1.PNG

Regards,

Hey @ricardosanchezm 

 

Can you try adding one other user to the team and share the flow with them to check if it is behaving the same way? Basically, I observed that the flow should be in shared team flows to appear on the teams tab. And this can happen only when you actually share it with another user in the organization and add them to that particular team in teams. (makes sense?)

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Hi @yashag2255 ,

I added the user as member in the Team.

1.PNG

I have shared some flows with the user with Run only permission.

3.PNG

The flows appears in the Teams Flows section in the Flow portal

4.PNG

The flows still does not appear in the flow tab 

2.PNG

I added the user as Owner of one of the flows.

5.PNG

Still no flows are listed in the flow tab

6.PNG

Besides this, these does not make me a lot of sense because there are some flows that I wish do not share with the Team that are for personal use only. What I expect to see are my full list of flows and for the members of the Team just show them the flows that have been shared with them.

 

Regards,

Hey @ricardosanchezm 

 

I just checked, you need to share the flow with the team (using the team name in teams). For example, see the screenshot below, I have the team name as TradeDetails and i used that name to share the flow:

gsggs.PNG

 

It will then display in the teams tab irrespective of the members. 

 

Hope this helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

 

Hi @yashag2255 ,

I have tried this without success. I have shared the flow with the Team of Teams.

1.PNG

The flow does not appear in the flow tab.

2.PNG

After this something strange has happen, I unshared the flow so no one has access to it.

3.PNG

When accessing the portal the flow still appears in the Teams flow section

4.PNG

Regards,

Hey @ricardosanchezm 

 

That is weird. Can you confirm that there is no user input required/ expected in the flow? Also, this flow exists in the default environment right?

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Hi @yashag2255 ,

 

Yes, there is no user input required in the flows and these ones exist only in the default environment. Also if I create a flow from the Flow tab in Teams the Flow can't be seen from there, but if I go to the portal the flow is visible in the Teams flow section.

 

Regards,

Had same issue. Shared it Run Only to the group teamgroupname@org.com and it worked.

Did you ever figure this out?

 

I had the same problem and accidentally solved it by adding Flow again. 

 

I did this by re-adding the Flow and chosing the specific team to publish it to.   This caused all my flows to appear.

 

Hi folks,

Suddently they appeared after months using the web portal. 

Anyway I really appreciate all of your help

Thanks and regards!

daniel_herrera
Advocate I
Advocate I

Did you ever figure this out?

 

My flow is at the default environment since apparently other environments are not supported. 

Owner of the flow is the Team itself , for automated flows and for manual flow is both Owner and run only. 

yet when i add the Power automate tab to my general channel is always empty. i do see the flows at the Power automate portal. but the tab is supposed to be the shortcut , otherwise this  app in teams is absolutely useless. 

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Users online (1,370)