cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
NavBoy
New Member

Cannot create Sales Line from CRM to NAV using MS Flow

Hi,

I'm receiving the following error for the "NAV Create Item" action in the Sales Line flow.

Dynamics NAV: Request failed: The remote server returned an error: (400) Bad Request. (Document No. must have a value in Sales Line: Document Type=Order, Document No.=, Line No.=0. It cannot be zero or empty.)

 

The Sales Header gets created in NAV and the Order No. is maintained in CRM. Now while passing the Sales Line, I'm sending this Order No. but in another field as the out-of-box Document No. doesn't show up in MS Flow field mapping. I even wrote a code in NAV on the first line OnInsert trigger to assign the values to these primary key fields but still Flow throws the same error.

 

Appreciate if you could provide any alternative solution to this problem.

Thank you

1 ACCEPTED SOLUTION

Accepted Solutions

Hi,

I used a different approach and I was able to fetch the value in NAV.

 

Thanks for your suggestion!

View solution in original post

2 REPLIES 2
v-yamao-msft
Community Support
Community Support

Hi @NavBoy,

 

From the error message, it seems that you haven’t provided values for Sales Line, Document Type, Document No.

I assume that you are using Dynamics 365 trigger When a record is created, what dynamic contents have you selected from the trigger for the NAV action Create item’s fields?

Could you check the return value of each dynamic content?

Besides, please make sure you are providing a valid value for each field. To know what exact value each field needs, please use the action Get item to get all the value from of a record.

After getting to know what exact value is needed for each field, please try again with valid value for corresponding fields.

 

Best regards,

Mabel

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi,

I used a different approach and I was able to fetch the value in NAV.

 

Thanks for your suggestion!

View solution in original post

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Users online (48,546)