cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
deeman
Frequent Visitor

Cannot export from PowerApps due to missing Flow

Hi guys,

 

I wasnt sure where to post this because its kind of related to both PowerApps and Power Automate.

 

I am trying to export my PowerApps App, however I am getting the following message:

 

" Could not find flow " < flow number> " '

 

In Power Automate. I have looked for this said Flow, and typing it in the URL I get the following message:

 

" This flow has been deleted".

 

So clearly a flow I used a while ago and then deleted.

 

So,

 

1) Is there a way to find the Flow and delete it even though I have deleted it from Power Automate and Power Apps?

 

2) Is there another way to export my App, even after deleting all the Flows from it? ( still get the same error)

 

Your assistance would be greatly appreciated.

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
CFernandes
Super User
Super User

Hello @deeman 

 

The error is popping up because the flow is still connected to your application.

 

  • To remove it from there, you need to open the app in the edit menu.
  • From the left menu, select Data Sources, remove the flow connection inside your app.
  • Save and Publish it.
  • Once it is published, try to reexport the app and let us know in case you still see the issue.

 

CFernandes_0-1634820584162.png

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

 

P.S. take a look at my blog here and like & subscribe to my YouTube Channel thanks.

View solution in original post

3 REPLIES 3
CFernandes
Super User
Super User

Hello @deeman 

 

The error is popping up because the flow is still connected to your application.

 

  • To remove it from there, you need to open the app in the edit menu.
  • From the left menu, select Data Sources, remove the flow connection inside your app.
  • Save and Publish it.
  • Once it is published, try to reexport the app and let us know in case you still see the issue.

 

CFernandes_0-1634820584162.png

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

 

P.S. take a look at my blog here and like & subscribe to my YouTube Channel thanks.

View solution in original post

deeman
Frequent Visitor

This worked! Thank you. The mistake I made previously was not publishing before exporting

 

thanks!

@deeman Wohoo.. I am glad that your problem has been resolved. 

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Users online (2,618)