cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
RussellGove
Kudo Kingpin
Kudo Kingpin

Cant update sharepoint items with people fields that allow multiple

 

 

Hi,

I have a flow that updates a sharepoint list item. The list contains  a people field that allows multiple people. The flow was working fine earlier this week. When I try to edit the flow today, if i edit the Update List Item task its asking me for 'Claims' for the people field. see below:


Capture.PNG

 

has something changed?

1 ACCEPTED SOLUTION

Accepted Solutions
v-yuazh-msft
Community Support
Community Support

Hi @RussellGove,

 

I have made a test on my side and you could refer to screenshot below to create the flow:

 

Capture.PNG

 

 

You could enter custom value in the "PeopleField Claims" fiels as below:

i:0#.f|membership|useremail

 

My flow would run successfully as below:

Capture.PNG

 

 

Best regards,

Alice

 

 

View solution in original post

4 REPLIES 4
v-yuazh-msft
Community Support
Community Support

Hi @RussellGove,

 

I have made a test on my side and you could refer to screenshot below to create the flow:

 

Capture.PNG

 

 

You could enter custom value in the "PeopleField Claims" fiels as below:

i:0#.f|membership|useremail

 

My flow would run successfully as below:

Capture.PNG

 

 

Best regards,

Alice

 

 

View solution in original post

I dont want to update the claims. I just want those fields to remain unchanged.

I retrive the item just bedfore i update it. 

Last week it was just letting me selecthe field  from the item i previously retririeved. 

Now all of a suden it is forcing me to enter all the claims.

 

 

My FLow looks like thisL

Capture.PNGU

 

I just want to use the vallues from GetItemAfterRegionalApproval when I update the item.  

 

The output of GetItemAfterRegionalApproval contains this:Capture.PNG

 

I want to use that RegionalAccountManager when I update the Item

 

I tried entering the following expression: 

body('GetItemAfterRegionalApproval')?['Regional Account Approver']

 

 

Capture.PNG

 

After I entered that expression, saved the flow and reloaded the brwoser the call looks like this:

Capture.PNG

So It looks correct. But when I rin it the update fails. with this:

Capture.PNG

 

 

 

 

DOH!

I needed to  sitch modes:

Capture.PNGAll good now!

Helpful resources

Announcements
MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Users online (62,861)