cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Sorte
New Member

Categorize & Flag email of a shared mailbox

Hello there!

 

I would like to share Flag & Categorize (colours) an email based on keywords & Sender. With power automate, I could not find the option "Categorize" so I tried to use the Inbox rules of 365 to categorize the mail and add an automation in power automate to flag it. Unfortunately, it does not work. I was doing some testing and outlook only categorizes the mail without flagging it.

In power automate I am using the following flow: 

 

Could someone help me out with this matter? I really appreciate it.

Sorte_0-1637164003827.png

 

Thank you and have a great day!

 

Sergi

7 REPLIES 7
VictorIvanidze
Community Champion
Community Champion

What happens if you disable the Outlook rule - do you see properly flagged emails?

--------------------------------------------------------------------------------------
Contact me if you are interested in custom Power Automate development.
Sorte
New Member

Hey there @VictorIvanidze unfortunately not. I do not know what's wrong with my automation but it does not work. The test fails, Am I doing something wrong?

Thank you,

Sergi

VictorIvanidze
Community Champion
Community Champion

Try to populate "Original mailbox address" field.

--------------------------------------------------------------------------------------
Contact me if you are interested in custom Power Automate development.
Sorte
New Member

Hello @VictorIvanidze, by populating the shared mailbox do you mean:

1. Adding a new license to the shared mailbox

2. Adding it to my account. If I add it to my account my outlook runs really slow.

 

I just want that outlook categorizes & flags mails when a certain condition is matched, i.g, contains keyword in "Body" or "Subject" or from a specific sender.

 

Thank you! 🙂 

VictorIvanidze
Community Champion
Community Champion

I meant filling "Original mailbox address" field in your "Flag email (V2)" action. Did you do that?

--------------------------------------------------------------------------------------
Contact me if you are interested in custom Power Automate development.
Sorte
New Member

Hello @VictorIvanidze. I added the Original Mailbox address and it works only when testing it. It does not work when the rule is applied and "ON" only in testmode. Do you know maybe a solution here? What am I doing wrong?

Thank you and have a great week!

VictorIvanidze
Community Champion
Community Champion

Hi @Sorte,

 

I'd recommend to disable a rule and use only PowerAutomate.

Here is an example how to assign a category to a message: https://www.ivasoft.com/assigncatflow.shtml

--------------------------------------------------------------------------------------
Contact me if you are interested in custom Power Automate development.

Helpful resources

Announcements
MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Power automate tips 768x460 v2.png

Restore a Deleted Flow

Did you know that you could restore a deleted flow? Check out this helpful article.

Users online (3,243)