cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
james_riach
Advocate IV
Advocate IV

Check if an attachment already exists in a SP list

Hello,

 

When an item is created in SP list A the Flow creates the same item in list B with attachments. That works fine. Now when the the item is modified in list A the flow is trying to make the same changes to the item in List B and is working to a point. The problem I am facing is that when the flow is trying to make the changes and add any new attachments to the item it hits the following problem: 

"The specified name is already in use.\n\nThe document or folder name was not changed.  To change the name to a different value, close this dialog and edit the properties of the document or folder.\r\nclientRequestId: 19504cc1-d7ba-4b67-9e2d-86526f7f7413\r\nserviceRequestId: a2887d9e-3054-6000-eb17-c62ae061486e"

So it is not working due to the name of one or more of the attachements already existing in the list for that item.

 

I want to try and find a way to check if the attachment already exists in List B and if it does only add new attachments that have been added.

 

Is there a way to do this?

 

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
v-yuazh-msft
Community Support
Community Support

Hi @james_riach,

 

Could you please share a screenshot of the configuration of your flow.

 

You could take a try to delete the item in the List B firstly, and then create a new item in the List B when an item is modified in list A.

 

Best regards,

Alice

View solution in original post

5 REPLIES 5
v-yuazh-msft
Community Support
Community Support

Hi @james_riach,

 

Could you please share a screenshot of the configuration of your flow.

 

You could take a try to delete the item in the List B firstly, and then create a new item in the List B when an item is modified in list A.

 

Best regards,

Alice

View solution in original post

Hi Alice,

 

Thank you for your reply.

 

I used your suggestion to delete all the attcahments first and then add them again and that has worked for me so thank you for your help with this Smiley Happy

 

James

Hey James,

 

I have an similar issue. Would be helpful if you share the Flow images you used to delete the existing attachment and added a new one? This one is troubling me a bit.

 

Thanks,


Santosh

Hi Santosh,

 

Sorry but I no longer use that Flow or list any more so have no screenshots I can share.

 

If you haven't already though I would recommend using the delete attachment function to delete all the attachments from your 2nd list to start with and then collect all the attachments from your 1st list and add them in to your 2nd list. This way you will not get the already exists issue.

 

Thanks

Hi James,

 

Thanks for the reply. Since i am updating the item list, i wanted to delete the specific attachment from that item and replace with a new one. Something which is currently not working for me. Let me check if i can get something on forum.

 

Thanks,


Santosh

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Users online (1,898)