cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
_kikilalaaa
Helper V
Helper V

Column not Found

Hi all. I want to filter a sharepoint list using "Get Items" with filter Query. I filter SharePoint List A based on value in SharePoint List B. However, it says that column not found even though its clearly there. 

 

_kikilalaaa_0-1616617566946.png

1. This is my SP List A, with V1.

 

_kikilalaaa_1-1616617635913.png

2. This is my SP List B with "V1".

 

3. However, when I try to get items, this error occur:

_kikilalaaa_2-1616617811661.png

this is veryyyy urgent, i hope you can help!

 

7 REPLIES 7
Mira_Ghaly
Dual Super User
Dual Super User

@_kikilalaaa

Please share full screens of your flow setup, I guess you are looping on List B and trying to get items from LIST A

So it should be like

Assigned_x0020_Village eq 'V1' 

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here

Hi I have tried your solution but same error shows up. Here is my detailed flow.

 

_kikilalaaa_0-1616642979383.png

_kikilalaaa_1-1616643111897.png

_kikilalaaa_2-1616643374511.png

 

_kikilalaaa_3-1616644194310.png

 

here is the error at "Get Items 2" details. Please help! Thanks

_kikilalaaa
Helper V
Helper V

hi @Mira_Ghaly , hope you can help. I do not know the error refer to which sharepoint list. I have recheck the sp list, both of them has data named 'V1' in "village name2" and "assigned village". i am so lost right now.

Mira_Ghaly
Dual Super User
Dual Super User

@_kikilalaaa 

Can you remove the single Quotes from below:

Mira_Ghaly_0-1617078934341.png

 

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here

HI @Mira_Ghaly ,

I have tried your solution but the same error occured. I tried to change the value in RV List (Assigned Village field) from V1 to V2. But the same error (Column V1 does not found) happens. So, I think it cannot detect items in Assigned Village field because V1 here refer to "Village Name2" right?

 

I also have tried to create new column in RV List, and name one of the item in row to "V1", same error still occur. now, i dont know what to do

Mira_Ghaly
Dual Super User
Dual Super User

@_kikilalaaa 

Can you show me on which step exactly it is failing and share screen of this step ..Thanks

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here

hi @Mira_Ghaly ,here is the step:

_kikilalaaa_3-1617165862778.png

 

here is the error:

_kikilalaaa_1-1617165768351.png

 

To view all process, you can just scroll up. thanks

Helpful resources

Announcements
Power Automate News & Announcements

Power Automate News & Announcements

Keep up to date with current events and community announcements in the Power Automate community.

Community Calls Conversations

Community Calls Conversations

A great place where you can stay up to date with community calls and interact with the speakers.

Power Automate Community Blog

Power Automate Community Blog

Check out the latest Community Blog from the community!

Users online (2,757)