cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
eduitguy
Regular Visitor

Comments not appearing in Approvals?

Good Evening,

 

I have a flow that asks approval for PD. After reach Approval before it goes onto the condition from Approval I have an Update Sharepoint Item set that places the Responses Comment into the Sharepoint list. I can see that the list on Sharepoint is updated, the output of the section does work.

 

However in the next Start and Wait section I have a Sharepoint Dymanic Expression of that updated section... though no data is put there.


Am I just being too hopeful that the Sharepoint list is updated in time... or would it be something else.

 

Cheers.

8 REPLIES 8
DCReina
Helper II
Helper II

Hey @eduitguy ,

 

Any chance you can post the expanded flow for us to look at? It would be extremely helpful in our efforts to help troubleshoot your issue.

 

Cheers,

 

DC

Jcook
Super User III
Super User III

Hello @eduitguy 

 

If you do updates inside the flow, you will want to query SharePoint again for the new updates. Unless you use the dynamic content from the update action its self.

 

yes please share a screenshot of your flow.


Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips,
tricks, and guides
FlowAltDelete





eduitguy
Regular Visitor

Morning,

 

Please find two images of my flows. First is a simplified look and the second is a full expanded look.

 

I am basically trying to get the Start and Wait comment added to Sharepoint so I can use them in below Start and Wait or at Yes or No alerts.


Cheers.

 

Power Automate - Simplified https://imgur.com/RcXgEDx 

Power Autoamte - Expanded https://imgur.com/DmeQCe0 

NOTE: I used imgur as the images were too large for direct embedding.

Hi @eduitguy 

 

Thanks for the pictures,

 

Can I ask at which point are you experiencing the error/missing values.

A picture of the Run just of the section that is causing issues would be great to troubleshoot.

 

Thanks


Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips,
tricks, and guides
FlowAltDelete





eduitguy
Regular Visitor

Jcook,

 

As you can see after the Start and Wait for Approval I have a Sharepoint Update Item that basically puts the Respones Comment back into the Sharepoint List (this works).

 

However in the next Start and Wait or Confirmation/Denial Email that goes back to the submitter I want to include that Responses Comment. However it is not getting added to those emails.

 

screencapture-australia-flow-microsoft-manage-environments-Default-d6cb0c2f-3760-4f7e-b373-6a29f9dda1d4-flows-4413735c-84c9-4b9e-93c5-5b7e33c31ff2-2020-07-31-08_18_07.png

Hi @eduitguy 

 

Check to confirm the dynamic content of the Comments are the correct dynamic values. If they are the correct values. Than you will have to do a Get Item right before the send email actions to grab the most recent data from SharePoint


Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips,
tricks, and guides
FlowAltDelete





eduitguy
Regular Visitor

Morning... thanks for your help so far.

 

I checked the running... it says it worked... but no comment is added to the email.

 

 

Output in email sent from Flow...

eduitguy_0-1596148337914.png

 

How it should be added...

eduitguy_1-1596148424430.png

 

And in the Sharepoint list it is updated.

eduitguy_2-1596148481607.png

 

And finally the Get Item that is before the send email.

eduitguy_3-1596148515172.png

 

I'm not sure what else can be done.

 

@eduitguy 

 

So the Get item action is where you are grabbing the dynamic content for the Comments?

 

Are you able to use the the Start and Wait for approval Comments Dynamic content for the email, like you have in the Update Item?


Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips,
tricks, and guides
FlowAltDelete





Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Users online (58,733)