cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Concatenatex Loses Delimiter When Passed to Flow

I have a PowerBI dashboard that uses the CONCATENATEX function to string together multiple IDs using commas. Example:

123

345

567

becomes 123, 345, 567

 

I am passing the concatenated list into PowerApps and then into Flow, which uses the concatenated list to execute a stored procedure to insert records into SQL. 

 

In the PowerApp I created a label to display the concatenated list and it displays fine. The issue is that Flow passes through to SQL 123345567 instead of 123, 345, 567. Does anyone know the cause of this and a solution?

 

1 ACCEPTED SOLUTION

Accepted Solutions
Anonymous
Not applicable

I ended up deleting and recreating the flow, which made it work.

View solution in original post

2 REPLIES 2
v-yuazh-msft
Community Support
Community Support

Hi @Anonymous,

 

Could you please share a screenshot of the configuration of your flow?

Please share more details so we would try to provide a proper workaround for you.

 

Best regards,

Alice

Anonymous
Not applicable

I ended up deleting and recreating the flow, which made it work.

Helpful resources

Announcements
Power Automate News & Announcements

Power Automate News & Announcements

Keep up to date with current events and community announcements in the Power Automate community.

Community Calls Conversations

Community Calls Conversations

A great place where you can stay up to date with community calls and interact with the speakers.

Power Automate Community Blog

Power Automate Community Blog

Check out the latest Community Blog from the community!

Users online (4,932)