cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Kudo Kingpin
Kudo Kingpin

Condition problems?

Anyone else having problems with flows connected to SP lists or similar.

I have a very simple flow just to locate the problem.

 

Before I save the flow: (notice the Title column in the condition)

 

before.png

 

 

11 REPLIES 11
Highlighted
Kudo Kingpin
Kudo Kingpin

Re: Condition problems?

The post was cut.

Here the rest:

 

After i save the flow it shows this: notice the title column again:

after.png

Highlighted
Kudo Kingpin
Kudo Kingpin

Re: Condition problems?

The advanced condition shows : @contains(item()?['Title'], 'test')
Is this correct? Im used to seeing triggerBody() and not Item()?

Anyway the flow is not working.
Am I missing something basic? I tried to replace item with triggerBody.
Any yes the list have an item that has a title containing test. 🙂
after_1.png

 

Highlighted
Microsoft
Microsoft

Re: Condition problems?

Thanks for reporting this.

We already create a bug and the fix is on the way.

 

 

Highlighted
Kudo Kingpin
Kudo Kingpin

Re: Condition problems?

In the example given, and since the output from Sharepoint Get Items is an array... will the "Condition" block apply to each array item? Or do we need to use "Filter array" instead, and apply "Filter array output" as the input for "Apply To Each"?

 

BTW, the bug also happens with Array Filter; i.e. when you implement Recurrence trigger+Sharepoint Get Items+Array Filter.

 

Highlighted
Kudo Kingpin
Kudo Kingpin

Re: Condition problems?

Hi, has this been fixed?

Highlighted
Kudo Kingpin
Kudo Kingpin

Re: Condition problems?

@kkurni fix been deployed? 🙂 thanks for any feedback

Highlighted
Microsoft
Microsoft

Re: Condition problems?

Yes, this should be fix now.

 

There was a problem with conditions for multi values which returned from GetItems Action.

The condition should be wrap inside for each.

 

You should see this flow instead.

(but if you still the old one, would you mind to try to recreate a new one ?)

 

Conditons get Items.png

Highlighted
Kudo Kingpin
Kudo Kingpin

Re: Condition problems?

Hmm seems to be adding a second for each as soon as I select a SP field to be added in either subject or body. And therefore not able to save it. If I drag the condition outside the first for each container, the flow is not taking into account the condition. It runs the action against all items/or none, regardless of the condition? Made a new flow. @kkurni

Highlighted
Microsoft
Microsoft

Re: Condition problems?

I cannot repro this on my ends.

 

@Rfla, But does it work when you make a flow ?

 

Thanks

Highlighted
Kudo Kingpin
Kudo Kingpin

Re: Condition problems?

Ok In my last test I did it agains a SP list of type tasks. Will try the again agains a regular SP list and get back to you @kkurni

Highlighted
New Member

Re: Condition problems?

I am still facing the condition problem. It still does not seem to be working for me.

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Users online (6,493)