cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Rfla
Kudo Kingpin
Kudo Kingpin

Condition problems?

Anyone else having problems with flows connected to SP lists or similar.

I have a very simple flow just to locate the problem.

 

Before I save the flow: (notice the Title column in the condition)

 

before.png

 

 

12 REPLIES 12
Rfla
Kudo Kingpin
Kudo Kingpin

The post was cut.

Here the rest:

 

After i save the flow it shows this: notice the title column again:

after.png

Rfla
Kudo Kingpin
Kudo Kingpin

The advanced condition shows : @contains(item()?['Title'], 'test')
Is this correct? Im used to seeing triggerBody() and not Item()?

Anyway the flow is not working.
Am I missing something basic? I tried to replace item with triggerBody.
Any yes the list have an item that has a title containing test. 🙂
after_1.png

 

Thanks for reporting this.

We already create a bug and the fix is on the way.

 

 

In the example given, and since the output from Sharepoint Get Items is an array... will the "Condition" block apply to each array item? Or do we need to use "Filter array" instead, and apply "Filter array output" as the input for "Apply To Each"?

 

BTW, the bug also happens with Array Filter; i.e. when you implement Recurrence trigger+Sharepoint Get Items+Array Filter.

 

Hi, has this been fixed?

@kkurni fix been deployed? 🙂 thanks for any feedback

Yes, this should be fix now.

 

There was a problem with conditions for multi values which returned from GetItems Action.

The condition should be wrap inside for each.

 

You should see this flow instead.

(but if you still the old one, would you mind to try to recreate a new one ?)

 

Conditons get Items.png

Hmm seems to be adding a second for each as soon as I select a SP field to be added in either subject or body. And therefore not able to save it. If I drag the condition outside the first for each container, the flow is not taking into account the condition. It runs the action against all items/or none, regardless of the condition? Made a new flow. @kkurni

I cannot repro this on my ends.

 

@Rfla, But does it work when you make a flow ?

 

Thanks

Ok In my last test I did it agains a SP list of type tasks. Will try the again agains a regular SP list and get back to you @kkurni

I am still facing the condition problem. It still does not seem to be working for me.

dhcabrasil
New Member

Im still having problems with contains when using data from sharepoint.

Helpful resources

Announcements
MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

May UG Leader Call Carousel 768x460.png

What difference can a User Group make for you?

At the monthly call, connect with other leaders and find out how community makes your experience even better.

PA Survey Carousel Image.png

We want to hear from you!

If you are a small business ISV/Reseller, share your thoughts with our research team.

Users online (3,650)