cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Frequent Visitor

Copy attachments from one SharePoint list to another list

Hello,

 

How do I create copy of a SharePoint list to another including attachments using MS Flow? 

 

Thanks,

Yash

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support
Community Support

If here you would like to copy one SharePoint list to another list, with the attachments involved, then please follow the steps below:

1. Add a manual trigger, then add a SahrePoint -Get items Action, specify the SharePoint site Address and List name (List 1),

2. Add the first Apply to each, within it, add SharePoint ->Get Attachments action, specify the Item ID from the Get items action:

3. After that, add a create item action, which is used to create item on List 2, map the value from List 1,

41.PNG

 

4. After Create item action, add Apply to each 2, specify the Get Attachments body as the Input, then add the Get Attachment content action, specify the Site Address, list name to List 1, Item Id Choose ID from the Get items action, file identifier choose from Get Attachments,

5. After that, add an Add attachment action, Specify the Site Address, list to List 2, item Id choose from the Create item action, File Name choose DisplayName from Get Attachments action, file content choose attachment Content from the SahrePoint Get Attachment content action,

42.PNG

 

 

Then save your Flow.

Running status from my side:

43.PNG

 

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

16 REPLIES 16
Community Support
Community Support

If here you would like to copy one SharePoint list to another list, with the attachments involved, then please follow the steps below:

1. Add a manual trigger, then add a SahrePoint -Get items Action, specify the SharePoint site Address and List name (List 1),

2. Add the first Apply to each, within it, add SharePoint ->Get Attachments action, specify the Item ID from the Get items action:

3. After that, add a create item action, which is used to create item on List 2, map the value from List 1,

41.PNG

 

4. After Create item action, add Apply to each 2, specify the Get Attachments body as the Input, then add the Get Attachment content action, specify the Site Address, list name to List 1, Item Id Choose ID from the Get items action, file identifier choose from Get Attachments,

5. After that, add an Add attachment action, Specify the Site Address, list to List 2, item Id choose from the Create item action, File Name choose DisplayName from Get Attachments action, file content choose attachment Content from the SahrePoint Get Attachment content action,

42.PNG

 

 

Then save your Flow.

Running status from my side:

43.PNG

 

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Anonymous
Not applicable

Under Get Attachments, I dont' see "ID" for id field, but see "Identity" instead. I try this value, but it doesn't work.

 

 

I had the same issue as VincentK and worked around it by using Compose (although I could have used a variable).

Is this a bug or am I missing something?

 

Compose.jpg

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott
Anonymous
Not applicable

I figured a way to work around it.  Just continue on to build your flow action. Under Get attachment content, highlight & copy "ID", then paste it under Get Attachments.

I have create my flow following the similar steps suggested in this response.  The flow saves, and it states it's running succesfully.  However, the file is not copied into the designated library nor is the attachment added. 

 

Heres my flow: 

 

Flow 1 error.JPGFlow 2 error.JPG

 

When I try and check why my flow is not working. Like I mentioned before it states the flow has ran succesfully but nothing has happen.  And when I drill down, it's graded out.  Please help. 

Flow 3 error.JPGFlow 4 error.JPG

 

 

Hi all,

 

I have the exact requirement - Copy attachments from one SharePoint list to another list.

I am going to try it out.

Thanks.

Did it work for you?

Hi,

 

Any solution to this in Sharepoint Designer, either 2010, or 2013? I don't want to use the Copy Item Action, rather the Create Item Action.

 

Currently I have a workflow which creates an item in a second list, once the first item is approved. Create Item allows me to custom map one field to another, rather than needing identical lists (as would be the case using Copy Item). The problem is, the attachments cannot be mapped (at least I can't see how to do it!).

 

Thanks,

 

Matt

I have implemented this and it works fine. But the Apply to each which has Get attachments, Get attachment content and add attachment fails with error "ActionFailed. An action failed. No dependent actions succeeded.". However, the attachment gets copied over nicely. Any clue on why this is failing. Thank you.

How would I modify this flow to just copy a single item?

So if an Item was approverd, copy that item only with its attachments (not the entire list) to list B

Never mind, just use the get Item instad if the get Items action 🙂

Thank you so much, this has been of great help!

 

 

Anonymous
Not applicable

@v-micsh-msft Do you know how to maintain the attachment file name from the native list to the destination list?

 

For example, the attachment file name in the native list is "Capture1",

but when I follow your flow steps, the attachement file name in the destination list changes to:

"__Id___%252fLists%252fRFA_Construction%252fAttachments%252f1%252fCapture%2b-%2bFLOW.JPG_,_AbsoluteUri___https___business.sharepoint.com_sites_ECHo_Lists_RFA_Construction_Attachme (1).SPListItemAttachment__:"

Hi @AlbertoSP - I have followed these steps and am noticing that when using Get Items, the items + their attachments are getting created in my other lists for each item the Get items list contains. I.e., if list 1 has 4 items in it, I mark item #3 as Approved to have it moved to list 2, the item is getting created a total of 4 times in List 2. I am trying to use Get Item as you mention here but I am then not able to select an output in the Apply to each; no dynamic content to select. How did you accomplish this? CC: @v-micsh-msft 

 

 
 

no-output.png

Power Automate
Power Automate

I created this video to clarify dependencies on this question. Please let me know if it is helpful.

 

https://www.youtube.com/watch?v=QoBKDJD0uZo

 

Thank you for your patience,

Audrie

Great video, I was having a problem getting the attachment content to come across and this solved it for me.  

 

Question, I will google it but do you have any idea of the file size limit for attachments?  I'm thinking it's around 50MB from my testing.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Users online (11,395)