cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Post Patron
Post Patron

Create new record in CDS using power automate

Hi All,

I have created a flow which will insert a row in CDS. I am facing issue while inserting record. Issue is my record is getting inserted but having null values. Flow is executing successfully but it is returning null value. What is the possible reason? 

flow.PNG

When I checked HTTPS, it is giving me expected output.

Flow https.PNG

When I check create new record it is giving me null values

Flow record.PNG

4 REPLIES 4
Super User III
Super User III

Hello @Tejasvi_munge 

 

Could you share a screenshot of your flow in edit more with the CDS action.





Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips, tricks, and guides
FlowAltDelete




Hi @Jcook 

 

As I am new to PowerApps I am not able to understand what flow in edit more with the CDS action. But whatever flow I created, I shared it already in question with screenshots.

FYI- I followed this blog- https://readyxrm.blog/2019/12/28/trigger-power-automate-flows-from-power-apps-portals/ ( this blog is for to update the record but I used to create a record)

 

Please let me know what can I do to clarify that.

 

Thank you.

Hi @Tejasvi_munge 

 

I was wondering what your Create a record action in flow is doing.

 

I basically want to see what fields you are adding to that action inside flow:

D2B05084-0700-459F-B7F1-70630C06B332.jpeg

 





Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips, tricks, and guides
FlowAltDelete




Hi @Jcook ,

 

Thanks for the reply!

Here is the flow-

record detail flow.PNG

 

I have doubts -

1.  Suppose my entity name is X and it has "Assessment" as a column(Primary field) in CDS and here in flow is a compulsory field.  But I don't have data for that returning from previous step. What should I do in that case?(For now, I have put Assessment as "interview_id" )

Assesment.PNG

2. Also, I have Age as column but when I select that I get option of "add dynamic content". But unlike other(Gender, interview_id etc), this particular age field doesn't give default option (option which suggest when I select that particular field) 

Age.PNG

 

The problem I am facing might be due to the Assessment or Age field I feel.

 

 

Helpful resources

Announcements
Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Users online (74,392)