cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
james1812
Frequent Visitor

Creating Approval List and linking it to the flow

Hi there,

 

I am trying to create a flow which gets approvers from a sharepoint list based on the responder of a form. 

 

However, when I try to GET ITEM from the responder email, it does not find this ID in the sharepoint list. Is there a way to format the text so that it is a match? I cannot change the formatting of the Sharepoint list as this is the "title". 

 

Many thanks. 

 

james1812_0-1608649167659.pngjames1812_1-1608649195648.png

 

1 ACCEPTED SOLUTION

Accepted Solutions

@james1812 

Your approval action should not be inside of a loop.  Take a look at my screen shot below.  To make it easier, I removed the Compose action and am using a variable instead.

Also, Did your Get items action return any values?  I should return 1 record.

image.png

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

View solution in original post

4 REPLIES 4
ScottShearer
Super User
Super User

@james1812 

The Get item action wants the SharePoint list item ID for the ID property - not the users email.

What you will need to do is use a Get Items action and use a filter query to limit the items returned to those where your the email address you have equals the email address stored in a column.

If the users email is stored in the title column, your filter query probably will look like this:

image.pngimage.png

 

Let me know if you need more help.

 

 

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott
james1812
Frequent Visitor

 @ScottShearer 

 

Hi Scott,

 

Thank you so much for this. The first bit works great. 

 

However, when trying to send the approval to the selected email, I am having some issues. 

 

When my flow looks like the below: 

 

james1812_1-1608655014484.png

james1812_3-1608655792761.png

 

I receive the below error relating to the approval:

 

james1812_2-1608655735125.png

 

If I change the "assigned to" step to the below: 

 

james1812_4-1608655930715.png

 

Then I receive the below error: 

james1812_5-1608656027187.png

 

Any further help would be much appreciated 🙂

 

Thanks! 

 

 

 

 

@james1812 

Your approval action should not be inside of a loop.  Take a look at my screen shot below.  To make it easier, I removed the Compose action and am using a variable instead.

Also, Did your Get items action return any values?  I should return 1 record.

image.png

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott
james1812
Frequent Visitor

Hi Scott,

 

Amazing, thank you - this works! Thank you so so much for all of your help 🙂 

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

Carousel_PP_768x460_Wave2 (1).png

2022 Release Wave 2 Plan

Power Platform release plan for the 2022 release wave 2 describes all new features releasing from October 2022 through March 2023.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

365 EduCon 768x460.png

Microsoft 365 EduCon

Join us for two optional days of workshops and a 3-day conference, you can choose from over 130 sessions in multiple tracks and 25 workshops.

Users online (5,804)