cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
KevinMS
New Member

Custom connector action with x-www-form-urlencoded content-type

Hi all,

 

I'm trying to build a custom connector around Twilio's fax API, but I'm having trouble creating a custom action around a POST request with an application/x-www-form-urlencoded content type. The POST request is described in Twilio's documentation here.

 

 

I can get the request to work with curl and in Postman, but with the custom connector, I keep getting a "missing required parameter" error, which makes me think that the request body is still being sent as json rather than the "key=val&key=val" format that the endpoint expects. I tried to set the Content-Type header manually, but no luck. Here is the relevant part of my openapi file. I've tried a few variants of this. Do I have something wrong, or is Flow just unable to handle custom actions with this content type?

 

"post": {
        "responses": {
          "default": {
            "description": "default",
            "schema": {
              "type": "string"
            }
          }
        },
        "consumes": [
          "application/x-www-form-urlencoded"
        ],
        "produces":[
          "application/json"
        ],
        "summary": "Send a fax",
        "description": "Sends a fax",
        "operationId": "SEND_FAX",
        "parameters": [
          {
            "name": "Content-Type",
            "in": "header",
            "description": "Content-Type",
            "required": true,
            "type": "string",
            "default":"application/x-www-form-urlencoded"
          },
          {
            "in": "formData",
            "type": "string",
            "description": "From",
            "name": "From"
          },
          {
            "in": "formData",
            "type": "string",
            "description": "To",
            "name": "To"
          },
          {
            "in": "formData",
            "type": "string",
            "description": "MediaUrl",
            "name": "MediaUrl"
          }
        ]
      }

 

15 REPLIES 15
NathanHowe
New Member

Re: Custom connector action with x-www-form-urlencoded content-type

Came across this post because I'm having the EXACT same problem. I'm trying to post to Twilio's fax API and have tried passing the parameters by URL encoding and as JSON, setting the content-type manually and not specifying it at all.  Every single time the Flow fails because the required 'To' parameter is missing.  Works fine in Postman but can't get it working in Flow.

 

Hoping you solved this.  Thanks!

thalesvalias
Frequent Visitor

Re: Custom connector action with x-www-form-urlencoded content-type

Same problem here, but with a private app. x-www-form-urlencoded - formDate param seems to be completely ignored by Microsoft Flow 😞

thalesvalias
Frequent Visitor

Re: Custom connector action with x-www-form-urlencoded content-type

Could solve that by changing the formData parameters to query paramenters.

GonzaloR Advocate I
Advocate I

Re: Custom connector action with x-www-form-urlencoded content-type

@thalesvalias  I'm having the same problem. Your suggested solution only works for simple parameters

{
"title":"Test folder"
}

But if you have nested parameters, or an array, it throws a different error:

{
  "project":
      { 
      "ownerIds":["KUAE6EG7"],
      "status":"Red",
      "startDate":"2019-09-31",
      "endDate":"2019-10-07"
       }
}

This is the error I get:

Your custom connector has been successfully updated, but there was an issue converting it to WADL for PowerApps: An error occured while converting OpenAPI file to WADL file. Error: 'Parameter with type='array' is not currently supported at JSON path paths./api/v4/folders/{folderId}/folders.post.parameters[3]'

 

I'm still searching for a solution (In this thread: Custom Connector - error: array not supported in parameter )

thalesvalias
Frequent Visitor

Re: Custom connector action with x-www-form-urlencoded content-type

Hey, at the end I haven't stick to my previous solution... I just let the params as they originally are, as formData, and it worked normally. The thing is that I was trying to use the Test mechanism from inside the connector, and the test for formData params seems messed up. So I just ignored the tests and used the custom connector on my flow and there it simply worked.

 

But in your case you're using PowerApps, I used MSFlow... so it might be different for you :(. Sorry, I wish I could helped you more.

 


@GonzaloR wrote:

@thalesvalias  I'm having the same problem. Your suggested solution only works for simple parameters

{
"title":"Test folder"
}

But if you have nested parameters, or an array, it throws a different error:

{
  "project":
      { 
      "ownerIds":["KUAE6EG7"],
      "status":"Red",
      "startDate":"2019-09-31",
      "endDate":"2019-10-07"
       }
}

This is the error I get:

Your custom connector has been successfully updated, but there was an issue converting it to WADL for PowerApps: An error occured while converting OpenAPI file to WADL file. Error: 'Parameter with type='array' is not currently supported at JSON path paths./api/v4/folders/{folderId}/folders.post.parameters[3]'

 

I'm still searching for a solution (In this thread: Custom Connector - error: array not supported in parameter )


 

GonzaloR Advocate I
Advocate I

Re: Custom connector action with x-www-form-urlencoded content-type

Thanks for sharing your workaround. 

Maybe I posted in the wrong forum, I actually am using Flow as well, because of the error message stopping me in the Custom Connector setup, I posted in the powerapps forum. 

 

I'm glad that it worked for you using formData, unfortunately the api I'm connecting to (Wrike) doesn't support that Content Type.

 

Since writing my post I tested in Postman and was successful in sending the request by adding the header Content-Type application/x-www-form-urlencoded - so I went back to the custom connector and added my parameters to the body, when I peek code everything shows up as I believe it should. 

 

And now I am in flow and stuck at the same place as the OP.

Highlighted
Frank37
Frequent Visitor

Re: Custom connector action with x-www-form-urlencoded content-type

Other api, same problem:

In Postman: works fine

In connector test function: works fine too:

 

Swagger-Editor:

paths:
  /auth/token:
    post:
      consumes: [application/x-www-form-urlencoded]
      produces: [application/json]
      parameters:
      - {name: client_id, in: query, required: true, type: string, default: myclient,
        x-ms-visibility: internal}
      - {name: client_secret, in: query, required: true, type: string, default: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx,
        x-ms-visibility: internal}
      - {name: grant_type, in: query, required: true, type: string, default: client_credentials,
        x-ms-visibility: internal}
      - {name: Content-Type, in: header, required: true, type: string, default: application/x-www-form-urlencoded,
        x-ms-visibility: internal}

But using it in PowerApp or Flow, I get status=415 error (wrong Content-Type)

 

It seems, the the microsoft server is changeing the header:

{
  "method":"post",
  "queries":{
    "client_id":"myclient",
    "client_secret":"xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx",
    "grant_type":"client_credentials"
  },
  "headers":{
    "Content-Type":"application/x-www-form-urlencoded"
  },
  "path":"/auth/token",
  "host":{
    "api":{
      "runtimeUrl":"https://europe-002.azure-apim.net/apim/connector-999999999999999999999999999999999999"
    },
    "connection":{
      "name":"/providers/Microsoft.PowerApps/apis/shared_connector-999999999999999999999999999999999999/connections/xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx"
    }
  },
  "authentication":{
    "scheme":"Key",
    "parameter":"*sanitized*",
    "type":"Raw"
  }
}

back to 

 

"Content-Type":"application/json"

 

GonzaloR Advocate I
Advocate I

Re: Custom connector action with x-www-form-urlencoded content-type

I was able to get mine working, I ended up putting the whole thing in the URL query.

For my problematic object I added it into the URL sample in PowerApps Custom Connector as:

 

&project=string

Then in Flow, I created a compose action and wrapped it in the following Expression:

string('{ "ownerIds":["KUAE6EG7"],"startDate":"2020-08-06"}')

image.png

 

It is working for now, so whatever re-formatting Flow is doing, forcing it into a string before-hand seems to do the trick for me.

Frank37
Frequent Visitor

Re: Custom connector action with x-www-form-urlencoded content-type

Hi Gonzalo,

 

yes: for your problem this workaround helps changing the url

 

Unfortunately not for me, because

 

"content-type": "application/x-www-form-urlencoded"
is a HTTP Header parameter and not changeable (or addable) with a compose action 

 

rojoshi
Frequent Visitor

Re: Custom connector action with x-www-form-urlencoded content-type

I got my API to finally work. Here is what I did:

1. Exported my postman collection

2. Converted the export JSON file into Swagger format

3. Then, in PowerApps Custom Connector, I opened my non-working connector in Edit mode

4. On Test tab, I opened the API in Swagger editor and pasted the Swagger code generated in step 2

5. I tried the API there itself and it returned a valid output

6. The problem here though is that the API only returns True or False values

7. So I had to edit the Swagger code a little bit so as to get a JSON response from the API. Used the link https://swagger.io/docs/specification/2-0/describing-responses/ for updating the Swagger

 

Hope this helps you.

GonzaloR Advocate I
Advocate I

Re: Custom connector action with x-www-form-urlencoded content-type

@Frank37 ,

Have you tried adding the header as a "New Policy"? It might be worth a try.

 

  1. Click "New Policy"
  2. Name your policy
  3. Select "Set HTTP header"
  4. Select the Operations (Actions) that require this header
  5. Header name: "content-type"
  6. Header Value: "application/x-www-form-urlencoded"
  7. Action if header exists: "override"
  8. Run policy on: "Request"

 

Frank37
Frequent Visitor

Re: Custom connector action with x-www-form-urlencoded content-type

@GonzaloR  Great Idea: it works 👍

Logi365
New Member

Re: Custom connector action with x-www-form-urlencoded content-type

This helped me.

Please remember to encode using base64 method

Logic Apps works with and supports other content types, but might require that you manually get the message body by decoding the $content variable.

https://docs.microsoft.com/en-us/azure/logic-apps/logic-apps-content-type#other-content-types

Ansar
Frequent Visitor

Re: Custom connector action with x-www-form-urlencoded content-type

How can I add a new policy

GonzaloR Advocate I
Advocate I

Re: Custom connector action with x-www-form-urlencoded content-type

While editing your custom connector:

1. Under the Definition tab scroll all the way down

2. The last section is called Policies

3. click +New policy

Helpful resources

Announcements
firstImage

New Ranks and Rank Icons released on April 21!

The time has come: We are finally able to share more details on the brand-new ranks coming to the Power Automate Community!

firstImage

Now Live: Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Community Summit North America

The top training and networking event across the globe for Microsoft Business Applications

Top Solution Authors
Top Kudoed Authors
Users online (7,142)