cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Janaboy
Helper I
Helper I

Date mismatch between flows

Dear Community, 

 

I have a weird issue.

I have created via PowerApps, Flow and Sharepoint list an Export permit system. 

There is a strange issue, but before i wrote that down a few words about the flow.

Flow: Submit a request from Powerapps to a Proxy sharepoint list via a simple Flow, then my main system pickup from the proxy list and start the approval flow.

My problem that i have a few users, if they submit a request for some reasons the date will be changed to yesterday.

How this looks:

Submit a Powerapps form ( i use this to formulate the date:  Text(Authorized_Date.SelectedDate,"[$-en-US]yyyy-mm-ddThh:mm:ss"), then it will be written into a Sharepoint list (via a Proxy flow), the data looks like this:

2021-02-04T00:00:00

Then my main Flow, pickups the list entry and starting the approval flow.

But in that case it shows already the previous day:

2021-02-03 (the is the date from the 'When item is created').

What is the most strange, that it is working fine for most of the users, but i have one (at least what i am aware of) who has issues almost constantly. (I have a test system, but there is no problem, however using the same methods.)

 

If i check the created/modified date it is -1 hour to my actual time, so i was thinking that maybe that is causing the issue, but it works for many users without any problems.

I was trying to use this format in the Proxy when creates items into the sharepoint list:

@{addminutes(triggerBody()?['Createitem_Date_of_export'],120)}

 

But i started to receive error likes this:

InvalidTemplate. Unable to process template language expressions in action 'Create_item' inputs at line '1' and column '2533': 'In function 'addminutes', the value provided for date time string '' was not valid. The datetime string must match ISO 8601 format.'.

 

Anybody has any ideas?

I actually consider this as a bug.

 

Thank you,

Br,

János

2 REPLIES 2
gabibalaban
Super User
Super User

Hi @Janaboy ,

Most probably the problem came from TimeZoneConversion of each user. Can you try to put a "Z" on the back of your powerapps formula: 

Text(Authorized_Date.SelectedDate,"[$-en-US]yyyy-mm-ddThh:mm:ssZ")  

This will let the system know that the time is in UTC timezone and don't need any conversion.

 

Hope it helps !

 

Hi @gabibalaban,

 

Thanks.

Not sure if it is helped, now looks like this the incoming data from Powerapps:

2021-02-08T00:00:00Z

 

This is the original one:

2021-02-05T00:00:00

 

But i will make this change in the live system as well.

 

 

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Users online (1,358)