cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Advocate V
Advocate V

Error responding to Flow Approval in Outlook

Hello,

 

I have an Approval Flow with an issue.  When the approver receives the email notification of the Approval Request, when they try to approve the request from within the email in Outlook or Outlook Mobile on iOS, they get a message that says "An error occurred. Try again later."  This is on a Flow that has been working flawlessly prior to this week.

 

If they go into Flow and approve the request there, it works.  The error message doesn't really give much to go on, and there are no errors logged on the Flow side of things.  Does anyone have any ideas on where to start with this?

111 REPLIES 111
Frequent Visitor

Excact same error here only with Outlook desktop version 1906. Issue started yesterday.

Advocate II
Advocate II

Same error here...

Regular Visitor

Same error here in the desktop version of Outlook.  Interestingly OWA works fine for approving flows.

Solution Sage
Solution Sage

Hi @AngryBatVoice ,

Does the issue still exist?

I have made a test on my side, it doesn't have the issue you have mentioned.

Perhaps there is some issue with the connector in your area recently.

For more information, please connect to the Flow support:

https://asia.flow.microsoft.com/en-us/support/

Best Regards,

Community Support Team _ Zhongys

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

Advocate I
Advocate I

Same here.  

I copied the flow, tried a couple of approvals and they work.  There doesn't appear to be anything wrong with the flow: all connections are in place.  The error is in the Outlook approval email, with the error message "try again" shown.  I'm hearing this is occuring in several flows.  The flow run history shows the jobs as active.  Is this an Outlook error?  A while back an Outlook release caused the approval link to fail.

Advocate I
Advocate I

Experiencing the same issue with a flow that has been running fine for 6+ months.  Started last week and still happening today.

 

Capture.JPG

New Member

Having the same issue here... 

A re-install of Office including re-creating the mail profile fixed it for one user but that may have just been pot luck, another user this solution didnt work on. 

Works in OWA and my approvals... just not outlook. 


Frequent Visitor

Same error with same build. Approval works in Outlook online & Flow but not in desktop version of Outlook.

Advocate I
Advocate I

Same issue since two weeks.

Open ticket with Microsoft, make a lot of tests with (for) them but no change...

Please MS, make Flow devs team and Office devs teams speack together before release updates...

Frequent Visitor

same problem with on-premis outlook build1906

1906 Build, still the same problem. 1904 runs fine. OWA works fine too.

Build problems?

I have had the same problem.  Everything worked fine the other week.

Advocate I
Advocate I

Any update for You ?

Same error here. Our flows have been working fine for months. Now none of them work.

 

Outlook version 1906

 

Official support answer was - we know the issue and our developers team is working to fix this. No specific schedule..

Nope, same error.  I've been getting by having my users utilize the Flow app and web.

Same error. We cannot use approval on Outlook client.

Answer from support

 

 the fix will be deployed by the end of 3rd week of this month i.e, until 20th.

 

Until the fix is deployed we request you to use approvals with the workarounds provided i.e,

  1. Approve the request from Outlook Web browser
  2. Approve the request directly from Flow Approval center

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Users online (3,802)