cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
New Member

Error updating a record in Dynamics 365 finance and operation fails

I have the following process:

 

1.) Created a new custom entity in Dynamics 365 finance and operation

2.) Pushing data to an external Azure database

3.) Third party app reads data

4.) Third party app created result record in a azure sql table

5.) created a flow to update my custom entity with the results above.

 

Any idea?

 

The problem is that I'm getting the following error :

 

{
  "status": 400,
  "message": "An error has occurred.  No resources were found when selecting for update.\r\nclientRequestId: 3294da62-9fef-4fb8-a900-36c27322b8bb",
  "source": "azne-per-fno-dev016e97056e3e72cc22devaos.cloudax.dynamics.com",
  "errors": []
}

 

here is a screenshoot of the flow:

 

Flow1.jpg

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Support
Community Support

Re: Error updating a record in Dynamics 365 finance and operation fails

Hi @Adde1 ,

 

The error message told that No resources were found when selecting for update in the "Update a record" action.

I afriad that you have entered wrong information in the "Update a record" action so the action couldn't find the record that you mentioned and update it.

 

Please make sure that the Object id, WorkID, LineNum, WorkType, dataAreald that you entered in correct in the "Update a record" action.

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

1 REPLY 1
Highlighted
Community Support
Community Support

Re: Error updating a record in Dynamics 365 finance and operation fails

Hi @Adde1 ,

 

The error message told that No resources were found when selecting for update in the "Update a record" action.

I afriad that you have entered wrong information in the "Update a record" action so the action couldn't find the record that you mentioned and update it.

 

Please make sure that the Object id, WorkID, LineNum, WorkType, dataAreald that you entered in correct in the "Update a record" action.

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

Join the new Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Top Kudoed Authors
Users online (6,946)