cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Svee
Frequent Visitor

Error while parsing JSON: 'Unexpected character encountered while parsing value: A. Path '', line 0, position 0.'

Hi there,

 

I have a flow created that uses SQL connector to connect to a database view and pulls records from there and adds few records to excel.

 

The flow is scheduled to run once a day and is generally working fine. But at regular intervals failing with the below error. Without changing anything in the flow the flow again runs successfully on the next day or even if i resubmit the flow on the same day.

 

Http request failed: the content was not a valid JSON. Error while parsing JSON: 'Unexpected character encountered while parsing value: A. Path '', line 0, position 0.'

 

Need immediate help on this.

Please suggest.

 

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Svee
Frequent Visitor

As posted by @jinivthakkar ,

 

yesterday

"Recently someone on the forum was getting the same error because the connector was blocked on the environment, by any chance do you have another environment, if yes please can you move your flow and try running the same ?

Also implementing a try catch finally would help to pinpoint the error or even help you in overcoming this 

https://www.youtube.com/watch?v=a6rGbJXsH1U&t=2s

Please check out the video, hope that helps."

View solution in original post

7 REPLIES 7
jinivthakkar
Super User
Super User

@Svee please share for which action you are getting the error, also please can you share a sample value for which you are getting the error

Hi,

 

Connector used in SQL.

Pulling data from a SQL DB View and Filter clause is used to filter the data between a range of dates.

The filter and the data pulled from view seems to work fine as immediately if i resubmit it gets successful.

Svee
Frequent Visitor

Anyone able to guide as why this error occurs intermittently?

Svee
Frequent Visitor

Hi, Please find below the screenshot where i get this error and also the flow is not failing always. Only some of them fail. 

Svee_0-1641870592471.png

 


The filter condition used in the query is 
WO_x0020_Date ge 2022-01-01 AND WO_x0020_Date le 2022-01-31

 

The same flow when submitted again runs successful.

Flow runs are like below, suddenly in the middle it fails one or 2 days.. then successful again.

Svee_1-1641870592476.png

 

 

Also because the error says unexpected character in Line 0 Position 0, I'm not able to track or spot the issue yet.

 

Any help would be very useful.

 

Thanks

Svee
Frequent Visitor

@jinivthakkar - Thank you, as per your suggestion in another message implementing try,catch,finally in my flow to handle the scenario. I believe that would be the ideal solution to manage the unpredictable error as above.

 

 

jinivthakkar
Super User
Super User

@Svee please accept as solution and close the thread, cheers !

Svee
Frequent Visitor

As posted by @jinivthakkar ,

 

yesterday

"Recently someone on the forum was getting the same error because the connector was blocked on the environment, by any chance do you have another environment, if yes please can you move your flow and try running the same ?

Also implementing a try catch finally would help to pinpoint the error or even help you in overcoming this 

https://www.youtube.com/watch?v=a6rGbJXsH1U&t=2s

Please check out the video, hope that helps."

Helpful resources

Announcements
 WHAT’S NEXT AT MICROSOFT IGNITE 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Register for a Free Workshop.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

September Events 2022

Check out all of these events

Attend in person or online, there are incredible conferences and events happening all throughout the month of September.

Users online (3,637)