cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
SravanLal
Frequent Visitor

Excel file corrupt - SP folder to Email (Outlook)

Hi All,

 

Good Day!

 

I am trying to create a flow, when an HTTP request is received, picks up files from SP Folder and sends them to a couple of recipients over email. The recipients and files are selected based on some conditions set. All is working fine, but the files sent over are corrupted. I have attached the ss of the flow and the error I get. Any help or suggestion is much appreciated.

Flow page 1Flow page 1

Flow page 2Flow page 2

Flow page 3Flow page 3

Flow ErrorFlow Error

 

Thank You!

1 ACCEPTED SOLUTION

Accepted Solutions
DamoBird365
Super User
Super User

Hi @SravanLal 

 

I think I have spotted this on Reddit too 🤣

 

Remove those double quotes around the contentbytes dynamic content.  It's an object and by putting quotes around it, you make it a string.

 

DamoBird365_0-1630997028231.png

 

I've also a video on sending multiple attachments via email here too https://youtu.be/9G9GNeknemg.

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Cheers,
Damien


P.S. take a look at my new blog here and like & subscribe to my YouTube Channel thanks 😉

View solution in original post

4 REPLIES 4
DamoBird365
Super User
Super User

Hi @SravanLal 

 

I think I have spotted this on Reddit too 🤣

 

Remove those double quotes around the contentbytes dynamic content.  It's an object and by putting quotes around it, you make it a string.

 

DamoBird365_0-1630997028231.png

 

I've also a video on sending multiple attachments via email here too https://youtu.be/9G9GNeknemg.

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Cheers,
Damien


P.S. take a look at my new blog here and like & subscribe to my YouTube Channel thanks 😉

View solution in original post

Hey @DamoBird365 ,

 

Yea, it's me. Kinda desperate to get a fix for this. 😅

 

I did try removing the quotes, but that returned the value as null and the flow failed. Any idea why?

I will try to create one based on your video. I will update here once done.

 

Error: Parameter 'Attachment Content' cannot be null or empty.

 

SravanLal_0-1630998450029.png

 

 

 

Hi @SravanLal 

 

How strange that it is null.  What does the history of the get file content look like?  This is where you should see the file content.

 

Damien

Hi @DamoBird365 ,

 

Sorry, it was my mistake. The dynamic content I added in between was different. I removed the quotes and It's working well now. Thank you so much.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Users online (2,016)