cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
NathanFra
Helper II
Helper II

Excel file corruption

Working with an outside vendor that sends a daily status report email to an Admin email account. I have set up a very simple flow that will take the attachment they send (.xlsx) and place a copy of it in a SharePoint document library. The original idea was that they file they send would overwrite the previous day's submission.

 

I've tested this myself by just sending an image to see if the flow would pull out the attachment and had no issue. The flow would even overwrite the previous file if they were named the same thing. 

 

The original file is a 35KB Excel document, but in the SP library it is a 1KB file. I checked the email account, and the file opens fine there. But when opening the file in the library this is what I get:

NathanFra_1-1611879684924.png

 

Here is the flow I used originally with .JPEG that worked when I tested sending the email from my account to the Admin account.

NathanFra_2-1611879798480.png

NathanFra_3-1611879867865.png

 

Would it matter if the user is not in our tenant as a guest account?

1 ACCEPTED SOLUTION

Accepted Solutions
Gopala_Krishna
Solution Sage
Solution Sage

@NathanFra 

 

That doesn't matter if the user is not in your tenant as your are trying to extract email attachment and flow is running in context of your user account. The issue here is only with file content how that is being created

 

Can you please try changing the include attachments option on the trigger to YES and on the create file action in the file content instead of directly passing the attachment content pass it in a binary format. For that you can use the expression base64tobinary("AttachmentContent"). 

 

Make the above mentioned changes and check if that helps with overcoming the issue

 

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

If the information shared helps you, please consider giving a thumbs up 👍 and mark solution as resolved.

View solution in original post

1 REPLY 1
Gopala_Krishna
Solution Sage
Solution Sage

@NathanFra 

 

That doesn't matter if the user is not in your tenant as your are trying to extract email attachment and flow is running in context of your user account. The issue here is only with file content how that is being created

 

Can you please try changing the include attachments option on the trigger to YES and on the create file action in the file content instead of directly passing the attachment content pass it in a binary format. For that you can use the expression base64tobinary("AttachmentContent"). 

 

Make the above mentioned changes and check if that helps with overcoming the issue

 

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

If the information shared helps you, please consider giving a thumbs up 👍 and mark solution as resolved.

Helpful resources

Announcements
 WHAT’S NEXT AT MICROSOFT IGNITE 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Register for a Free Workshop.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

September Events 2022

Check out all of these events

Attend in person or online, there are incredible conferences and events happening all throughout the month of September.

Users online (4,401)