cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Morghan
Helper IV
Helper IV

Exception from HRESULT: 0x80131904 when deleting item from a list (follow-up)

Hello,

 

I originally posted this about a week ago and @manuelstgomes was able to provide some insight but I am seeing more occurrences of this intermittent 400 error upon deletion of an item in a list. All other actions complete successfully (delete item is the last action).

It's now happened 9 times in the past 232 runs, which again isn't a bad percentage, but wanted to re-open my original post here to keep it open for any other suggestions of what may be causing this or how to alleviate it.

 

My original post: ttps://powerusers.microsoft.com/t5/General-Power-Automate/Exception-from-HRESULT-0x80131904-when-deleting-item-from-a-list/m-p/446630#M44631 


Error:

 

{
"status": 400,
"message": "Exception from HRESULT: 0x80131904\r\nclientRequestId: 3ef3954b-1930-4ed2-8799-cca39b482550\r\nserviceRequestId: 3ef3954b-1930-4ed2-8799-cca39b482550"
}

 

 

Thank you in advance,

M

14 REPLIES 14
Dowsetts101
Frequent Visitor

Hey @Morghan just out of interest did you ever end up getting a resolution on this particular error? I've just encountered the same error, whilst creating a new items in a list. At least this time the new error details pane in Power Automate helpfully pointed me in the direction of this post (after I had googled first and found it anyway!!!).

 

This run was just a test run for me as I finalise this particular flow, so dont know if its recurring or not, but would be interested to hear how you got on.

 

Simon

 

Dowsetts101_0-1605077660846.png

 

Hi @Dowsetts101 - I never heard any other suggestions on how to fix this. I still see the error on rare occasions and just deal with those particular cases manually (by manually deleting the item the workflow fails to do automatically). Will continue to keep this thread open for any suggestions

zwelding
New Member

I am getting this issue as well. Its very annoying as I have to then sift through potentially hundreds of items each week to manually delete. 

After posting I had a thought after reading a few other suggestions in that SQL might be getting over whelmed making the changes in the backend. I then remembered I had parallelism enabled and was running 20 at a time in my apply to each loop. I turned that off so that it ran sequentially and then everything worked as expected. Hopefully that can help someone else with this issue!

Hi @zwelding  thank you for the input! However, I'm not sure how to apply this to my specific use-case. How would I disable parallelism in a PowerApps flow for the Delete Item action?

 

Morghan

@Morghan Click on the Action item "three dots" - Settings - Disable Concurrency. Concurrency for parallel action in Power Automate. 

juresti
Continued Contributor
Continued Contributor

Thanks @zwelding 

 

This solved the issue for me. I started seeing this over the weekend and first I tried removing and adding the action.

Then I saw your suggestion and it made sense since we normally use concurrency control on loop actions.

 

I turned it off and it processed every record successfully.

So this fixes the issue.

krish11
Helper I
Helper I

Thank You So much! This post really helped me to resolve that Delete Items Issue. Now I am able to delete all items from SharePoint List.

max81
Kudo Kingpin
Kudo Kingpin

I had the same problem.

2 Flows were running since month. Till last week, they failed because of the concurrency settings. Even on really small lists (4 items).

So thanks for the "tip". 🙂

Hello,

 

I am having a very similar issue; however I can't find the settings you are suggesting in the Delete item box. I doo se a concurrency control in the entry action "when an item is created", Limit is off. Is this what is refered in your suggestion?

 

Otherwise, this is what I see in the Delete item action:

2021_05_12_17_22_40_Power_Apps.jpg

 

In this menu, I see the following options:

2021_05_12_17_25_45_Power_Apps.png

 

Regards

 

First You required the Delete item step under Apply to each step. Then click on Apply to each setting. And you will get a concurrency control setting.

 

krish11_3-1620855475837.png

 

 

krish11_2-1620855390335.png

 

 

 

Thanks @krish11 , 

 

I see it it!

JWhiteFEI
Advocate II
Advocate II

Is there a resolution for this error that would still allow for concurrency control to be on? It worked in my Flow on a Apply to All>Delete a Sharepoint Item for months and now I get the above error.

I now get this error even with Degree of Parallelism set to 2.

max81
Kudo Kingpin
Kudo Kingpin

@JWhiteFEI : for me: just delete the concurrency value. than it works again and I can delete several 10k items.

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Users online (22,330)