cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
WK-PA2020
Helper I
Helper I

Exclude an Approver if they are the Submitter (Requester)

Hi, 

 

Please note that I have a flow that has 4 approvers and usually one of them is requesting the form for approvers.  I want to exclude the requester from approving this form since his approval is inherited and no need to approver from his side.

 

I need this to be dynamically done. 

 

I am using "when the item is created", "initializing variables, then it will go for approvers "start and wait for approval (all must approve)".  I think the step of excluding the approver should come before the start and wait for approval (all must approve). 

 

I appreciate your help with this issue. 

 

Thanks. 

 

Waleed. 

1 ACCEPTED SOLUTION

Accepted Solutions

Thanks Scott. 

 

It is working now, I re-arranged the emails!!

 

Once again thanks for your support.

 

Waleed

View solution in original post

20 REPLIES 20
ScottShearer
Super User
Super User

@WK-PA2020 

Please see my screen shots below.   I populate an array with the names of all approvers.  Then I loop through the array and compare the created by email to the array element.  Please note that Flow is case sensitive - be sure the enter the email addresses with that in mind or your condition won't work properly.

image.png

image.png

image.png

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

Hi Scott, 

 

Shall I include all the emails in the initialize variable (all approvers) in the value place?

 

Please note that I already have an Initialize variable to get all responses!  (after when item is created).  Is this affecting your steps?

 

Thanks. 

 

@WK-PA2020 

All approvers should be included in the array.  My loop adds approvers to the string variable only if they are not the creator of the item.

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

Hi Scott, 

 

I put the emails in the value as: 

"wwwww@nnnnnnn.com",

"kkkkkkk@nnnnnnn.com"

 

I received the below message and the flow failed:

 

The variable 'VarApprovers' of type 'Array' cannot be initialized or updated with value '"         @           com"
" @     .com"' of type 'String'. The variable 'VarApprovers' only supports values of types 'Array'.

 

Thanks. 

 

Waleed

May I should include: 

 

]

 

[

 

 

Hi Scott, 

 

I put 3 emails and one of them to the requester but it failed and gave the below message, but before a few minutes I tried 2 emails one of them for me and it is succeeded!

 

The variable 'VarApprovers' of type 'Array' cannot be initialized or updated with value '[
"         @      .com",
"         @              .com",
"         @    .com",
]' of type 'String'. The variable 'VarApprovers' only supports values of types 'Array'.

 

Thanks, 

 

Waleed

@WK-PA2020 

I believe that removing the last comma in your array will resolve your issue.  The comma separates elements of the array and should not be included after the last element.

 

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

I amended the emails and removed ( , ) from the last email in the end and now it gives me the below message: 

 

"There's an error in your flow preventing the creation of Approvals. Use the link below to learn more about the errors with your flow and/or environment configuration."

 

And in the Start and wait for approval is giving the below message: 

BadRequest. The request failed. Error code: 'InvalidApprovalCreateRequestAssignedToNoValidUsers'. Error Message: 'Required field 'assignedTo' contained no valid users in the organization'.

 

Thanks.

Hi Scott, 

 

When I remove the 3rd email it is working and the fill as follows: 

 

[
"            @       .com",
"            @       .com
]

I removed the comma (,) and now giving me another message:

 

There's an error in your flow preventing the creation of Approvals. Use the link below to learn more about the errors with your flow and/or environment configuration.

 

And in the Start and wait for approval is giving the below message: 

BadRequest. The request failed. Error code: 'InvalidApprovalCreateRequestAssignedToNoValidUsers'. Error Message: 'Required field 'assignedTo' contained no valid users in the organization'.

 

Thanks. 

@WK-PA2020 

It sounds as though none of the approvers were added to your string.  Take a look at your run to verify.  Refer to my example above which works.

 

 

 

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

Hi Scott, 

 

This is the solution as per PA but still, I cannot determine the solution. 

 

Thanks.  

Thanks Scott. 

 

It is working now, I re-arranged the emails!!

 

Once again thanks for your support.

 

Waleed

Hi Scott, 

 

Is it ok to put 3 emails or more in the initialize Variables?  Actually I am doing 3 emails but it is giving the same message and error that the emails not found but when I try 2 of them it is working!!

 

Thanks. 

@WK-PA2020 

You can add as many approvers as you would like.  Please post an updated screen shot of your Flow if you need help.

 

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

Hi Scott, 

 

I have 2 approvers in addition to me, for 3 of us it is not working and I am the requester!  In case I put my self and one of them it is working and correctly ignoring me as I am the requester and that means the error that the user is invalid and not found in the organization is wrong. 

 

I rearranged the emails in initialize Variables but without no hope but earlier it succeeded!

 

Really I do not know what is the problem. 

 

Thanks, 

Hi, 

 

Any help on this issue? 

 

Thanks, 

 

Waleed

tzucker
New Member

This is close to what I want to do, but I can't get it to work. (I only want to exclude myself for now - so the script does not have to determine the address dynamically.  I am the only approver and don't want to have to approve all of my own uploads.)

 

Excuse my newbie questions - this is the first time I am using power automate.  I have attached the flow below.  I am not sure what it means by the error at the top of the page:

 
The power flow's logic app flow template was invalid. Unable to process template language expressions for action 'Apply_to_each' at line '1' and column '1480': Expected an expression, but found string literal 'varApprovers' instead. 
 
I thought I copied this from the suggestions on this page.

FireShot Pro Screen Capture #072 - 'Edit your flow I Power Automate' - us.flow.microsoft.png

@tzucker 

In you Apply to each loop you have typed in varApprovers.  Rather than typing it in, you need to select varApprovers from Dynamic properties.

image.png

 

 

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Power Automate Designer Feedback_carousel.jpg

Help make Flow Design easier

Are you new to designing flows? What is your biggest struggle with Power Automate Designer? Help us make it more user friendly!

Users online (2,127)