cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
gersontun
Frequent Visitor

Execute Excel Script - Unauthorized

Hello,

In order to accomplish a couple of things I cannot do directly in Power Automate, I started executing regular expressions using the "Run Excel Script" activity. It had been working fine, but on Monday it started to fail. This execution of the Excel script is inside of an "Apply to each" activity.

What I've done so far to try to fix it:

1. Removed default concurrency to the trigger, so I make sure this process is not executing multiple times in parallel.

2. Removed default concurrency of the "Apply to each" activity, to make sure the process is not trying to execute the script multiple times at the same time.

3. On the Run Excel Script, I've played with the Retry Policy, with no luck.

The issue persists.

The weirdest thing is that this issue might or might not happen on the same execution and within the apply to each.

The Error:

gersontun_0-1632951157850.png

 

In the apply to each activity:

Execution number 5 failed, number 6 succeeded and number 8 failed again.. and so on.

Failed:

gersontun_1-1632951247286.png

Succeeded:

gersontun_2-1632951283538.png

Failed:

gersontun_3-1632951323916.png

 

This is the configuration of the RunScriptPageNumber:

gersontun_4-1632951777533.png

Hope anyone here can help!

 

UPDATE: Now that I am editing the flow, the issue started appearing on the top like this:

gersontun_1-1632952564540.png

 

It seems like the file was not available or I didn't have permissions on the file.

The excel file is saved and closed, no one else is using it.

 

6 REPLIES 6
Yutao
Microsoft
Microsoft

Hi @gersontun ,

 

Sorry to hear you're experiencing this problem. It might be an issue on our side and we have been actively investigating the root cause. Will let you know once it's been addressed. Thanks for your patience!

 

Yutao

younceb
Advocate I
Advocate I

Currently having the exact same issue. Yesterday (EST 9/29) I was completely unable to get an Office Script to run from a flow, but this morning it has executed twice successfully - but just now did not work. I double checked with our global admin, and it is enabled for use.

 

Today:

younceb_1-1633004846455.pngyounceb_2-1633004946935.png

 

 

 

 

Yesterday issue, apologies didn't get a good screenshot. But it was the same error as OP.

 

younceb_3-1633005226862.png

 

The suggested community posts for the failure were very helpful to find this thread

Yutao
Microsoft
Microsoft

Hello @younceb and @gersontun -

 

The issue should be addressed now. Can you please give it a try and see if your flows are working now? Thanks again for the patience!

 

Yutao

 

 

gersontun
Frequent Visitor

It's seems to be working now.

Yes, appears to be working again.  Thanks for fixing 🙂

younceb
Advocate I
Advocate I

It is indeed working well now! Thanks so much

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Users online (2,933)