cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
svignesh
Frequent Visitor

Exporting and Importing a Power Apps with Power Automate (flows) in a solution doesn't work

I am having a Canvas App that calls couple of Power Automate on button click. The Power Automate makes a rest api call queries against managed properties and returns results. It all works fine in the Dev environment.

 

I have them all inside a solution. When I export this solution and import it to a different environment, and when I visit the URL of the canvas app and hit search button, I get the below error message

 

 

 

"PowerAutomateName.Run failed: Connection not configured for this service"

 

 

 

It works fine only after I edit the PowerApps, click on the search button -> click on Action-> Power Automate -> click on the Power Automate again so that loads it up and update the code to PowerAutomate_1.Run("parameters")  

 

Or I had to remove the Power automate from the app and add it again and paste the code to make it work. Basically I have to refresh the PowerAutomate reference. It doesn't work out of the box when I import the solution and I have to make all these manual changes. Is there a way to avoid this?

 

Any help or suggestion would be appreciated

0 REPLIES 0

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Users online (1,856)