cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
RemiChambard2
Advocate III
Advocate III

Expressions not updating issue

I have a very strange and annoying issue. 

 

When I try to update an expression in a "If" statement for exemple, the expression is not updated the first time. I have to update it 2 or 3 times before the Power Automate editor takes it into account.

 

More detailed steps on what I do :

 

1. I set an expression in a "If" statement. The expression is saved correctly

2. I click on the expression "tag" in the "if'" statement to update it

3. I update my expression and click the "Update" button

4. When I hover the expression "tag", I don't see my update but the older version

 

I have to repeat steps 2 and 3 multiple times before my change is correctly saved.

 

I'm using the latest version of Edge Chromium Beta Channel.

6 REPLIES 6
JohnAageAnderse
Memorable Member
Memorable Member

Hello @RemiChambard2 

I had the same issue some time ago. Now I just carefully make sure to click on the Update button - and it always updates. I have not investigated further, but by firmly (which is kind of difficult to do with a mouse) clicking the Update button, it works for me 🙂

I am using both Chrome (latest) and Firefox (latest)

Kind regards, John

After reading your comment, I had to click and hold the Update button and that ended up working. It's so bizarre.

Hi @RemiChambard2 

 

This is a known issue for a while. What I generally do is copy the existing expression and remove the mapping, copy the expression back and modify it accordingly. Pretty sure its a bug but its a known issue for a very long time.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials
Yoshi_Snowball
Regular Visitor

Thank you for this solution! This has been an enduring frustration with Power Automate. It's ridiculous that one needs to click and hold "update" for changes to save.

test222221
Advocate I
Advocate I

2 years later and a problem still exists 🙂 

@PRB1313 posted the solution - you really do just have to click and hold (like 3-4 seconds) the "update" button to make the changes stick. So bizarre.

Helpful resources

Announcements
 WHAT’S NEXT AT MICROSOFT IGNITE 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Register for a Free Workshop.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

September Events 2022

Check out all of these events

Attend in person or online, there are incredible conferences and events happening all throughout the month of September.

Users online (3,286)