cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Solution Sage
Solution Sage

Facebook trigger on new post

Hello everyone,

When I post to my timeline on Facebook, a flow that is triggered from the Facebook trigger on new post works.
If someone else, posts on my timeline the flow never runs. Can someone help?
Thank you.

2 REPLIES 2
Community Support
Community Support

Hi @Mike8,

 

Could you please share a screenshot of your flow's configuration?

 

I have made a test on my side and don't have the issue that you mentioned. The "When there is a new post on my timeline" trigger would be fired when there is a new post on the logged in user's timeline.

 

Please check if someone else has posted some message (new post) within your Facebook timeline rather than their own timeline.

 

In addition, please check if the connection to the trigger is invalid, if yes, please update the connection and then check if the issue is solved. More details about updating a connection within Microsoft Flow, please check the following article:

Update connection in Microsoft Flow

 

You could consider take a try to re-create your flow on your side, then check if the issue is solved.

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hello @v-xida-msft,

Thank you for your reply.

FlowFacebook.PNG

 

"Please check if someone else has posted some message (new post) within your Facebook timeline rather than their own timeline."

This is the case. Someone else has posted on my timeline and the trigger didn't fire. Why?

The trigger is "When there is a new post on my timeline" so I think it should fire regardless who posted on my timeline.
But it doesn't. So, I am missing something here.

Also, in an other flow, when I use the action "Get feed from my timeline", it returns only the posts I have created.
If you, Kris, post something to my timeline, I can see it on Facebook, but when I try to retrieve using the "Get feed from my timeline" action, it's not there.

Is it supposed to be like this?

Helpful resources

Announcements
Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Users online (69,513)