cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
emberkrumwied
Helper II
Helper II

Failed/Not Failed Action

I have a fairly complex flow that recently has started to throw an error that says ActionFailed not dependent actions succeeded yet the flow continues and completes as expected.  Since the flow is really complex I'll just post action pics up to the failed/not failed action.  I'd be happy to share any specific action details if needed.

emberkrumwied_0-1670366471027.png

emberkrumwied_1-1670366512232.png

The Condition-OutsidePartyCheck is the action that is failing/not failing.

emberkrumwied_2-1670366580025.png

The flow runs on a SharePoint document library where invoices are loaded and multiple data fields are completed for each upload.  Once the data entry is done the flow is manually started by selecting a specific item and running the flow.  I have checked all the records and none of the dependent fields are blank.  I'm just extremely curious as to why this error is occurring because even though it is saying no dependent action was executed, the flow continues and results in the expected outcome.

 

Any ideas of what I am missing that might be causing this error/fail message?

 

UPDATE:  I've been doing some digging and think I might have zeroed in on where the issue is arising but I'm not sure how to fix (or if it even needs to be "fixed").  After gathering data points there is a Condition action to check for a specific value in a specific column.  If that value is present then the flow goes one way if the value is not present then there is a Start and wait for approval action.  This action is set with a 2 day duration.  The parallel branch below is there to either capture the response (if within the first 2 days) or a delay branch which will run once the initial approval action has timed out.  This delay branch was created to send out and track the number of follow up approval requests sent to the user.  It loops through the item waiting till it has received a response to the request, once received the flow continues on its way.

 

The Condition action is being shown as "failed" whenever the initial response isn't received within the initial 2 days (sometimes it takes our users longer to review and approve invoices).  So the Condition action is shown as failed, the initial approval request has no status indicator (neither the black "x", red "!" or green checkmark), the capture branch has the black "x" (since the response wasn't received in the first 2 days) and the delay branch all show as green checks (because the user finally responded to one of the follow up requests).

 

So I guess my question is two-fold...since the flow is essentially/eventually successful should the error showing on the Condition action bother me and/or is there a way to "tell" the Condition action to not show as "failed" until all of the delay branch attempts have been exhausted versus failing as soon as the initial approval request action times out?

 

emberkrumwied_0-1670510547605.png

 

 

 

 

0 REPLIES 0

Helpful resources

Announcements
Power Automate News & Announcements

Power Automate News & Announcements

Keep up to date with current events and community announcements in the Power Automate community.

Community Calls Conversations

Community Calls Conversations

A great place where you can stay up to date with community calls and interact with the speakers.

Power Automate Community Blog

Power Automate Community Blog

Check out the latest Community Blog from the community!

Users online (5,273)