cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Failed flow cannot be found in Azure

I was notified of failed flows (timeout, waited for approval > 30 days), however Azure cannot find the flow. See error message below. Within the past 30 days the Flow was moved from 'My Flows' to 'Team Flows', could this be a reason why the flow cannot be foud anymore? Also, is there a way to resubmit the flow?

 

 

Request to Azure Resource Manager failed with error: '{"error":{"code":"WorkflowTriggerHistoryNotFound","message":"The workflow '4796d050-3b32-4d83-abe8-3d148b9bcf82' trigger 'When_a_new_response_is_submitted' history '08586679305860403557565903755CU43' could not be found."}}'.

 

Thanks. 

4 REPLIES 4
v-bacao-msft
Community Support
Community Support

Hi @Anonymous,

 

It may be that the Flow was moved from 'My Flows' to 'Team Flows' causing issue.

 

You could recreate a similar flow and move it from 'My Flows' to 'Team Flows' to see if the same error occurred.

 

As for "a way to resubmit the flow", do you want to resubmit Approval?  

 

If you couldn't find it in Azure, you could find the corresponding Flow in the Microsoft Flow portal, click on the failed Run History, and resubmit.

 

Please take a try.

 

Best Regards,

Barry

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi Barry,

 

I have the same issue than Miche. I confirm that I tried to move a flow from "My flows" to "Team flows" by exporting it in zip and importing it in "Team flows". The thing it that I don't manage to create a flow directly in "Team flows". It creates it in "My flows" (I'm new to MS Flow, sorry). How should I do instead to avoid getting this failure?

 

thanks!

I have the same issue.  Occurred after changing the name on the trigger item.  

 

Request to Azure Resource Manager failed with error: '{"error":{"code":"WorkflowTriggerHistoryNotFound","message

… and the fix:  I went ahead and made a copy of the flow.  Don't ask me why, but the copy worked just fine.  Would seem as if (based on dates and number of times the issue seems to be expressed) something is needed to fix the problem instead of working around a broken product.

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Users online (1,979)