cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
MysticPp
Regular Visitor

Filling in forms

Hello other users!

I'm new to Power Automate Desktop (PAD) and I search the internet for my answer, but I can't get the information or help I needed. 

This is what I did:
1. Start excel.
2. Get the first free Column and Row.
3. Read all the data of the Excel file. I choose this 1 because my Excel data can change every day.
4. For each ExcelData make Name company.
5. Start Edge and go to the website to fill in the form.
6. Fill in the first field with the data out of Excel. 


When the data is extract from my Excel file and filling up a form, its filling up all my date from row 2. For example:
Name company     Addres name
MysticPp BV           Yellowstone 71

First field: MysticPp BV, Yellowstone 71.

Is there someway to fix this? On multiple youtube channels I see that it workt, except for me. 

This is how it looks then:

MysticPp_0-1631196110711.png

And this is how it looks in PAD:

MysticPp_1-1631196152970.png

Yours sincerely, 

Patrick





1 ACCEPTED SOLUTION

Accepted Solutions
VJR
Solution Supplier
Solution Supplier

Hi @p_doc,

 

This is how my Excel looks like

VJR_1-1631622584826.png

 

Inside the For loop I am displaying the first column value from my Excel (ie; ABC)

 

VJR_0-1631622555801.png

 

 

It correctly shows the first value 

 

VJR_3-1631622733783.png

 

 

 

And then writing the same value to a Web element

 

VJR_4-1631622821116.png

 

 

 

Please make sure you are using the correct syntax  %CurrentItem['Name']%

 

If still not working please show me all the variables and all stages and actions.

 

 

View solution in original post

9 REPLIES 9
p_doc
Helper I
Helper I

Hi @MysticPp ,

 

You can try changing the excel format to text.

VJR
Solution Supplier
Solution Supplier

Hi @MysticPp 

 

Do check out the setting for considering first row as header or not.

 

VJR_0-1631506518559.png

 

MysticPp
Regular Visitor

Hi @p_doc ,

Thank you for your reply. The format was allready text. Do you have a other solution or know somebody of the community who can knows the answer?

Yours sincerely,

Patrick

MysticPp
Regular Visitor

Hi @VJR ,

 

Thank you for your reply. The setting was allready turned on. Do you have a other solution or know somebody of the community who can knows the answer?

Yours sincerely,

Patrick

VJR
Solution Supplier
Solution Supplier

Hi Patrick,

 

I think I will be able to help you on this but the issue is not fully clear to me.

I am unable to co-relate between the Name, Company columns and the Nummer screenshots you have pasted.

 

Can you elaborate once again the full details on the issue along with how it is currently and how it should be?

MysticPp
Regular Visitor

Hi @VJR , 

It seems that message wasn't placed. First of all thank you for trying to help me. English is not my native language, so apologies for my text.

What i'm trying to reach
Our company get's application threw e-mail and that will be saved in a Excel file. Then we fill up a form on the internet by hand. I'm hoping that with PAD it will go automatically.

Excel file
The Excel file looks like this:

MysticPp_0-1631619111627.png

Each column and cell contains data, what is text. 

PAD
Here is a example what I made in PAD with a translation to English:

MysticPp_2-1631619308592.png

 

1. Start Excel.
2. Get the first free column/cell out of the Excel worksheet.
3. Read all the data of the Excel worksheet minus the empty cells.
4. For each ''Company'' in Excel.
5. Start the webform.

6. Focus on the first UI-element from that form.
7. Fill the first UI-element with cell A2 (company name) in this example ''Taxi''.

The following thing occur

MysticPp_3-1631619474351.png


The UI-element doesn't fill up only cell A2 (in this example ''Taxi'') but the whole row.

Do you maybe know what I did wrong?

Yours sincerely, 

Patrick

 


 

VJR
Solution Supplier
Solution Supplier

Hi @p_doc,

 

This is how my Excel looks like

VJR_1-1631622584826.png

 

Inside the For loop I am displaying the first column value from my Excel (ie; ABC)

 

VJR_0-1631622555801.png

 

 

It correctly shows the first value 

 

VJR_3-1631622733783.png

 

 

 

And then writing the same value to a Web element

 

VJR_4-1631622821116.png

 

 

 

Please make sure you are using the correct syntax  %CurrentItem['Name']%

 

If still not working please show me all the variables and all stages and actions.

 

 

View solution in original post

MysticPp
Regular Visitor

Hi @VJR ,

Thank you that worked. 

Now I have a other question. If it needed that I start a new topic on the forum, then I will make that. 

I added a extra row to the Excel file. In PAD I made a loop that for each company I do the same actions. When its finished with row 1, start browser up etc. When he try to find the same UI-element, its says I cannot find it. 

Here is my screenshot of PAD:

MysticPp_0-1631710055408.png

When I removed the ''Focus'', its gives me the following error:

MysticPp_1-1631710229710.png
Cannot write in text field. I hope that you can help we with this.

Yours sincerely, 

Patrick

Hi @VJR ,

My question is no more needed. I needed to close the browser and wait 3 seconden. It worked! Thank you so much.

Helpful resources

Announcements
MPA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Users online (1,692)