cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
chydewf1
Frequent Visitor

Filter array has stopped working

Since this morning one of my flows is not working as it did yesterday - the filter array function doesn't appear to be working?
1 ACCEPTED SOLUTION

Accepted Solutions

Thanks for your ideas, in the end I found using the filter function in the 'get items' action worked best. Created ge 'formatDateTime(addDays(utcnow(),-7),'yyyy-MM-dd')' Thanks Chris

View solution in original post

4 REPLIES 4
chydewf1
Frequent Visitor

Screenshot_1.png

This is the formula in the filter array box:

 

@greaterOrEquals(formatDateTime(item()?['Created'], 'MM/dd/yyyy'), formatDateTime(addDays(utcNow(), -7), 'MM/dd/yyyy'))

Hi @chydewf1,

 

Thanks for providing the detailed screenshot.

I am afraid that you will have to remove the Apply to each from the flow.

I have made a flow likes below which is working perfectly.

The formula being used in the filter array action is just what you are using:

@greaterOrEquals(formatDateTime(item()?['Created'],'yyyy-MM-dd'),formatDateTime(addDays(utcNow(), -7), 'yyyy-MM-dd'))

 

Please check the screenshot and try again with it on your side.

1.PNG2.PNG 

 

Best regards,

Mabel

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thanks for your ideas, in the end I found using the filter function in the 'get items' action worked best. Created ge 'formatDateTime(addDays(utcnow(),-7),'yyyy-MM-dd')' Thanks Chris

View solution in original post

Helpful resources

Announcements
MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Users online (39,875)