cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Anonymous
Not applicable

Flow Approval Condition not working!!!!

I'm using the approval flow template "Send form responses for approval" and it doesn't seem to matter if I approve or reject the approval request, the condition always returns as false!

 

The Start an approval step has outputs to condition; condition is "Response is equal to Approved" but when I approve the request by email, the condition is not accepted. 

 2019-02-14 15_18_43-Edit your flow _ Microsoft Flow.png2019-02-14 15_19_53-Run History _ Microsoft Flow.png

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Hi @Anonymous,

I have checked the templates of the Approval in Flow.

I think it’s a mistake of this template ‘Send form responses for approval’.

3.png

The condition value should be Approve.

I will raise this issue to MS team.

Thanks for your attention.

Best Regards,

Zhongys

View solution in original post

15 REPLIES 15
Highlighted
Resolver III
Resolver III

Hi @Anonymous

In  your condition, try with "Response" is equal to "Approve", not Approved.

Loose the "d".

 





Did I answer your question? Mark my post as a solution!

Proud to be a Flownaut!





Highlighted
Anonymous
Not applicable

Yeah, I found that about 5 minutes after posting. 

 

Of course, begs the question why Microsoft's own TEMPLATE has that error. Here is the UNCHANGED template:2019-02-15 10_43_17-.png

Highlighted

Hi @Anonymous,

I have checked the templates of the Approval in Flow.

I think it’s a mistake of this template ‘Send form responses for approval’.

3.png

The condition value should be Approve.

I will raise this issue to MS team.

Thanks for your attention.

Best Regards,

Zhongys

View solution in original post

Highlighted

Dear Team,

I am currently having the same issue with my flow. The email that goes out after an approval or rejection is made is the same thing for the second approver. I used "Response is equal to Approve" as my condition yet i am not getting the desired outcome. 

Attached is a screenshot of my condition.

Kindly assist.

Approval.png

Highlighted

I have the same issue, losing the 'd' in Approved doesn't help...

 

Highlighted

Don't use the Start an approval as that is no longer supported or works. Instead use Start and wait for an approval or possibly Create an approval.

Then use Outcome is equal to Approve. The Response is equal to Approve is not the current working action.

Rob
Los Gallardos
If I've answered your question or solved your problem, please mark this question as answered. This helps others who have the same question find a solution quickly via the forum search. If you liked my response, please consider giving it a thumbs up. Thanks.

Highlighted
Frequent Visitor

Thank you, it worked after I changed 'Response' to 'Outcome'

Highlighted

This worked for me.

Thank you very much.

Highlighted

Hey @RobElliott

 

It is still not working in my case. Kindly check it. aaaaaaa.JPG 

Highlighted

@mirtiza you say it's not working, but what's not working? Are you getting an error message in the flow? Is it always going down the ref If no channel after the approver has approved it? It looks like you are saving the approval to a SharePoint list so what's in the column where you are saving the approval decision? Just saying it doesn't work gives us no clue as to what's happening.

Rob
Los Gallardos

Highlighted

Sorry @RobElliott  my Question was not clear. 

The problem is my condition was not working. I want to update item when approver approves. The flow has no error but the problem is when the approver approves, the Condition was not proceeding forward.

May be Condition is not True thats why it wont proceeding forward. Kindly help me to do this  

 

Highlighted

@mirtiza one thing you need to check is that there isn't a space after the word Approve in the Condition as that's quite a common error. When you've checked that could you run the flow and post a screenshot of what happens at the condition and the actions after it.

Rob
Los Gallardos

 

Highlighted

Exactly! 

Must have Outcome instad use Response

Highlighted

Hi Rob, 

 

If the outcome is Approve, it should send an email to me saying that the doc has been approved. If it is rejected, then an email should be sent saying that the doc had been rejected. However, regardless I approve or reject, I still receive the reject email. 

Highlighted

@Selenayk please post a screenshot of your flow and what the condition is. Without that there is no way we can work out what's going on.

Rob
Los Gallardos

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Top Solution Authors
Top Kudoed Authors
Users online (13,088)