cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
pNabin
Advocate V
Advocate V

Flow Powershell permissions required to run Maker cmdlet Get-FlowRun

I am running cmdlet Get-FlowRun <FlowName>.

Scenario1: I created a flow, run multiple times to get the flow run history. Get-FlowRun <FlowName> gives the flow run history.

Scenario 2: I share this flow to another user (who is admin of the environment)  so the user became Owner & Environment Admin of the flow. When that user run  Get-FlowRun <FlowName>, it doesn't gives the flow run history.

 

What permission is required for the second user, to get the flow run history?

1 ACCEPTED SOLUTION

Accepted Solutions

No worries @v-yamao-msft ,

I tried another microsoft tenant and it is giving the correct result. So, there is nothing wrong with my script but something wrong with settings in previous Environment (Tenant).

Thanks,

Nabin

 

View solution in original post

3 REPLIES 3
v-yamao-msft
Community Support
Community Support

Hi @pNabin ,

 

Please make sure the shared user has signed in with proper credentials and is using the correct flow name.

 

I have made a test according to your description, share the flow with user, then the user became owner & Environment Admin of the flow, Cdmlets Get-FlowRun will return the run details properly on shared user side.

 

Please check the following blog for a reference and try again with it:

https://docs.microsoft.com/en-us/power-platform/admin/powerapps-powershell

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi @v-yamao-msft ,

Yes I did enter the correct credentials so it is showing other flowruns for flow which is created by the shared user.
Similar is the case when tried other way around. UserA created and shared with UserB, then the flow run is not showing if the user is not the creator of the flow (but only a owner).

 

Any other possible causes of error that you think of?

 

Thanks,

Nabin

 

No worries @v-yamao-msft ,

I tried another microsoft tenant and it is giving the correct result. So, there is nothing wrong with my script but something wrong with settings in previous Environment (Tenant).

Thanks,

Nabin

 

View solution in original post

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Users online (1,300)