cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Sammy
Level: Powered On

Flow Running and never completing

I had a Flow which ran with no issues at all. From last week I am now having issues where the Flow runs constantly and never completes. Here is an outline of my Flow and can go into the finer detail if need be.

 

Does anyone know what the issue with this is?

$RM8HMJ0.png$RWENOX6.png

 

 

11 REPLIES 11

Re: Flow Running and never completing

You have an approval in the apply to each step - so the flow is going to wait and wait until the approver has either rejected or approved it!

 

Why do you have an approval in the loop?

 

Please check to see that the approver has received the approval mail!

 

If all else fails, try removing the approval step! or move it outside the loop.

 

Kind regards, John

Sammy
Level: Powered On

Re: Flow Running and never completing

Hi John,

 

Thanks for your reply. The approver is not even getting the email which is the problem so it must be failing at that stage. I tried to take the Start an Approval out of the loop and the Flow failed. Please see screenshot. 

 

Gov.png

Re: Flow Running and never completing

What I see is that it is your approval step that you need to look at! Please open it up and show us the details!

Ensure that you are using a valid recipient!

Kind regards, John

Sammy
Level: Powered On

Re: Flow Running and never completing

Here is a screenshot if the approval step. Please let me know if you think anything needs changed

Gov.png

Re: Flow Running and never completing

Ok, the first step you will have to do, is to ensure that the Assigned to field does contain a valid e-mail address.

You can either enther a manual e-mail address, yourself, to verify that it does send out an approval e-mail to you.

Or you can check the processing information in the Get response detail step and see what the value is of the field "Email of the W..." value that you are using in the Assigned to field!

 

Good idea is always to test any e-mail sending by sending to your own e-mail first. 🙂

Kind regards, John

Community Support Team
Community Support Team

Re: Flow Running and never completing

Hi @Sammy,

 

Could you please share a full screenshot of your flow's configuration?

Could you please show more details about the error message (Which action holds this error)?

 

I agree with @JohnAageAnderse's thought almost, you could send an approval email to yourself for testing before sending it to other approvers. I think this issue is related to your flow's configuration.

 

If you add the "Start an approval" action within the "Apply to each" action, please make sure that you have filled proper email address within Assigned to field of "Start an approval" action. Sending an approval email to a user who is not in your organization using "Start an approval" action is not supported in Microsoft Flow currently.

 

In addition, please make sure that the approver has received your Approval Request email. If the approver has received your Approval Email, please make sure that the approver has approved or rejected your Approval Request. If the approver didn't make response to your Approval Request, the "Apply to each" action would run constantly. You could consider take a try to send an approval email to yourself for testing.

 

I have made a test on my side and the flow works well. My flow's configuration as below:2.JPG

 

 

If you add a "Start an approval" action outside the "Apply to each" action (Just as the flow screenshot that you provided), you could not reference the dynamic contents from the "Get response details" action within "Start an approval" action. Referencing dynamic content from actions which is inside a "Apply to each" action within these actions outside the "Apply to each" action is not supported in Microsoft Flow currently.3.JPG

 

 

If reference the dynamic contents from the "Get response details" action within "Start an approval" action (Move the "Start an approval" action outside the "Apply to each" action), the error would show up as below:4.JPG

The flow fails as below:5.JPG

 

 

 

Best regards,

Kris

 

 

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Sammy
Level: Powered On

Re: Flow Running and never completing

Hi Kris,

 

Thanks for your response.

 

The reason the Approval is within the "Apply to Each" is because the "Assigned to" is not a manually input email but it is dynamic content from a MicroSoft Forms question. Therefore I can't take it out of the "Apply to Each".

 

The problem I am having is that I am testing it with my own email address in place of that field and it is still working sometimes and not working sometimes with no explanation as to why.

 

Thanks

wheineman
Level: Powered On

Re: Flow Running and never completing

Is there anything wrong with having an Approval inside of an Apply-to Each?

 

In my scenario, 

1) The flow is triggered by a Recurrence, every Monday morining.

2) I then have an Apply-To Each loop which pulls the next review date for every item in the library.

3) I use a Switch inside of the Apply-To Each in order to determine if an annual review is needed

4) If Yes, it launches an Approval for the targeted item

5) The flow seems to be "Running" until all newly launched approvals have been completed.

 

I have not changed it because it works. But it does lead to some flows running for days or weeks until the approver actually completes their approval task. Is there a better way, or is this a case of dont fix it if it aint broke?

Re: Flow Running and never completing

Hello Wheineman

There is nothing wrong with having the approvals done inside the loop. As you experience, it may take a long time (limited to 30 days).

I would suggest though, that you pull the approval outside your flow itself, as another flow, and call that for every item in your loop.

This will allow your main flow to finish and you can then see all the approval flows that are waiting for the approver.

Kind regards, John

wheineman
Level: Powered On

Re: Flow Running and never completing

Can you point me towards information on how I can call another flow from within my current recurrance flow?

Re: Flow Running and never completing

What I did for a similar situation, was to make a separate flow that uses the trigger "When a HTTP request is received" to which I added the item id as a URL parameter "&itemId=<your item id>".

The "itemId" can be retrieved from the URL using the expresion "TriggerOutputs()['queries']['itemId']" in the next step. Now start the approval steps that you need.

 

In your main flow, for each item that needs to be approved, call the above flow using a HTTP request and remember to add your item id at the end of the URI.

FlowHTTPcall.png

 

 

 

 

 

 

 

 

In the approval flow, it is a good idea to use a Response step to report back to the calling main flow, that all is OK. Like this:

FlowHTTPresponse.png

 

 

 

 

Hope this helps you on the way 🙂

Kind regards, John

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors (Last 30 Days)
Users online (4,737)