cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
TJ2
Frequent Visitor

Flow & Approval Emails

Hello,

 

I set up an approval flow with conditions. For "approved" an email is suppsoed to go out, and for the "rejected" response, a different email is supposed to go out. No matter which answer I choose, I get the "rejected" response email. What am I doing wrong? Right now, I have the condition set to "Response is equal to Approved" then it has the two choices, yes and no. The Yes/Approved info is supposed to populate into a SharePoint list. Since there are no "apprroved" res[pnses yet, the list is unpopulated. 

1 ACCEPTED SOLUTION

Accepted Solutions
AlanPs1
Resident Rockstar
Resident Rockstar

Try setting your condition to this and trying again:Capture-087.png

 

equals(body('Start_an_approval')?['response'], 'Approve')

If you have found my post helpful, please mark thumbs up.

If this post has solved your problem, please click "Accept as Solution".

Any other questions, just ask.

Thanks, Alan


Did I answer your question? Mark my post as a solution!

Proud to be a Flownaut!


View solution in original post

11 REPLIES 11
AlanPs1
Resident Rockstar
Resident Rockstar

Hi @TJ2

Please post a picture of your flow, any errrors and any relevant detailed information that will assist us in looking into this for you?

Thanks, Alan


Did I answer your question? Mark my post as a solution!

Proud to be a Flownaut!


TJ2
Frequent Visitor

Approval Flow.png

 

 

AlanPs1
Resident Rockstar
Resident Rockstar

Can you post the run state of the Flow too, regardless of error or success ... I can't tell from just the Flow if it is returning true or false or indeed erroring.

Thanks, Alan


Did I answer your question? Mark my post as a solution!

Proud to be a Flownaut!


TJ2
Frequent Visitor

It comes back as successful. An email does go out, but only the "rejection" email. Flow Test.png

AlanPs1
Resident Rockstar
Resident Rockstar

Try setting your condition to this and trying again:Capture-087.png

 

equals(body('Start_an_approval')?['response'], 'Approve')

If you have found my post helpful, please mark thumbs up.

If this post has solved your problem, please click "Accept as Solution".

Any other questions, just ask.

Thanks, Alan


Did I answer your question? Mark my post as a solution!

Proud to be a Flownaut!


View solution in original post

TJ2
Frequent Visitor

Thank you! It did populate in the SharePoint list, and I didn't get a rejection email, but I didn't get an approved email either. 

AlanPs1
Resident Rockstar
Resident Rockstar

Hi @TJ2

Is that problem solved for you, ie, it is working?

Or, does this now clarify you just aren't sending the email? ... If so, click on one of the "green ticks" and expand the "send email" on both "approved" & "rejected" to see what is happening with the send email action. feel free to post back with that graphical information.

 

If you have found my post helpful, please mark thumbs up.

If this post has solved your problem, please click "Accept as Solution".

Any other questions, just ask.

Thanks, Alan


Did I answer your question? Mark my post as a solution!

Proud to be a Flownaut!


TJ2
Frequent Visitor

Yes, I have the yes and no boxes. The approval is supposed to trigger an entry into a SharePoint list (which is does now with your help, thank you). And both responses either an approve or reject are supposed to trigger email responses. Email.png

AlanPs1
Resident Rockstar
Resident Rockstar

That's great news @TJ2, please click "Accept as Solution" on the post that resolved your issue. It helps those looking for the same issue in the future.

 

All the best to you!

Alan


Did I answer your question? Mark my post as a solution!

Proud to be a Flownaut!


 

Approval_change.pngIn condition please change the text from Approved to  Approve. Hopefully this works. As this is expected behaviour now.

AhmedKhodir
Frequent Visitor

just set it to "Approve" instead of "Approved"

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

Users online (24,308)