cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Regular Visitor

Flow based on VSTS onworkitemcreatedv2 keeps triggering

I have a flow based on VSTS / Azure Devops "onworkitemcreatedv2", which simply posts me all Prio 1 Bugs into a Teams channel. All worked fine until today, it keeps firing, although the Bug is already done & closed. Any ideas?

8 REPLIES 8
Community Support
Community Support

Re: Flow based on VSTS onworkitemcreatedv2 keeps triggering

Hi @njhfmstr ,

 

Could you share a screen shot of your flow?

 

From your description, it seems that the flow keeps running and posting the bugs that already done into Teams.

 

I have made a simple test using the following flow. However, only when the Bug is created, the flow will be triggered.

1.PNG

 

If possible, please try creating a new flow to see if the issue still exists.

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Regular Visitor

Re: Flow based on VSTS onworkitemcreatedv2 keeps triggering

Hey, 

it also worked fine for me until yesterday.

The only thing I made differently was, not creating a ticket from scratch but changing the type in Azure Devops into a Bug and then also cloned that one. And the clone keeps spamming / triggering the Flow, although it's already Done.

 

Screenshot 2019-05-21 at 09.07.39.png

Highlighted
Regular Visitor

Re: Flow based on VSTS onworkitemcreatedv2 keeps triggering

@v-yamao-msft  I activated the flow again, and created a new clean ticket, and it keeps posting to Teams every second. Please advise.

Highlighted
Frequent Visitor

Re: Flow based on VSTS onworkitemcreatedv2 keeps triggering

We're having exactly the same problem since Friday, May 10th (flow was not changed and working perfectly the last 7 months) . We had to stop the flow. Tried to reactivate it again today, but still the same problem.

Highlighted
Frequent Visitor

Re: Flow based on VSTS onworkitemcreatedv2 keeps triggering

Highlighted
Community Support
Community Support

Re: Flow based on VSTS onworkitemcreatedv2 keeps triggering

Hi @njhfmstr , @thom ,

 

Thanks for updating.

 

If you create a new flow, will the issue still happen?

 

If the issue still exists, please share a URL to the flow’s run details, I will help involve more resources to look into this issue.

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Frequent Visitor

Re: Flow based on VSTS onworkitemcreatedv2 keeps triggering

@v-yamao-msft I recreated my flow from scratch as you suggested (identical flow) and for now it seems to be working correctly indeed. Do you know what caused this problem on my old flow?

Highlighted
Regular Visitor

Re: Flow based on VSTS onworkitemcreatedv2 keeps triggering

@v-yamao-msft  i re-created the flows and it seems to work. what caused that issue?

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Users online (10,011)