cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper III
Helper III

Flow condition isn't working

Hi All,

 

I am trying to create a validation in my Powerapps that says true if all required fields are filled and says false if not all fields are saved (like in a save option).

 

When all required fields are filled my text field will be automatically set to true, which gives should forward to "If yes" and send an email to the approver of the ticket. like bellow

Validation true false.JPG

If I run a test with a item that's on True

Validation true false 3.JPG

The condition should process as true and lead to "If yes"but it doesn't..

 

Validation true false 2.JPGCan anyone help me on this? somehow it looks like Flow isn't picking up the value from a text field.

 

Thanks!

Ramon

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Super User II
Super User II

Re: Flow condition isn't working

Hello @Ramonnooijen 

Your text value of "true" is not the same as the expression "true", so it will alway be false!

This is how your condition should be (2nd in screenshot)

Flow.Condition.Text.True.png

Try this and tell us if it works for you 🙂

Kind regards, John

View solution in original post

5 REPLIES 5
Highlighted
Helper III
Helper III

Re: Flow condition isn't working

Anyone? 🙈

Highlighted
Super User II
Super User II

Re: Flow condition isn't working

Hello @Ramonnooijen 

Is your Validation column a text column (Single line of text)?

If yes, then the value you need to test for in the condition is "true" not the expression true!

If no, what is the definition of the column?

Kind regards, John

Highlighted
Helper III
Helper III

Re: Flow condition isn't working

Hi @JohnAageAnderse,

 

My Validation column is indeed a Single line of text.
In my powerapps I've created a formula that if all required fields are filled in this field will have a default setting: true and if not all fields are filled in the default setting will be false.

 

So if when an item is created in my SharePoint list the validation field is always filled with true or false, but somehow my flow doesn't recognize the text.value it always set to false.

 

Kind Regards,

Ramon

Highlighted
Super User II
Super User II

Re: Flow condition isn't working

Hello @Ramonnooijen 

Your text value of "true" is not the same as the expression "true", so it will alway be false!

This is how your condition should be (2nd in screenshot)

Flow.Condition.Text.True.png

Try this and tell us if it works for you 🙂

Kind regards, John

View solution in original post

Highlighted
Helper III
Helper III

Re: Flow condition isn't working

Hi @JohnAageAnderse,

 

Thanks a lot! I've tried that before, but somehow it didn't work.

Right now I tested again and it works 🙂 feel stupid that I couldn't make it work last time.

 

Thanks!

Ramon

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Users online (5,177)