cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Maorzd23
Level: Powered On

Flow failed - Get my profile

Hi all,

 

I built a flow that is activated by pressing button in powerapps. in the process I send an email to the current user.
In the tests I did, I used my personal email and it worked fine,
Now that everything works properly I used Get my profile to get to the email of the current user.
The first time it worked well, the next time it stopped working.

 

2.PNG

 

Does anyone know why this is happening?
Thanks in advance

4 REPLIES 4
JRaasumaa
Level 10

Re: Flow failed - Get my profile


@Maorzd23wrote:

Hi all,

 

I built a flow that is activated by pressing button in powerapps. in the process I send an email to the current user.
In the tests I did, I used my personal email and it worked fine,
Now that everything works properly I used Get my profile to get to the email of the current user.
The first time it worked well, the next time it stopped working.

 

2.PNG

 

Does anyone know why this is happening?
Thanks in advance


 

The error seems to show that you are pointing to a condition property that doesn't exist shared_office365users and it's looking for either shared_office365 or shared_sharepointonline.

 

Doublecheck your condition's yes statement to make sure the property is correct.

Maorzd23
Level: Powered On

Re: Flow failed - Get my profile

Thanks @JRaasumaa,

 

Unfortunately It's happens even if I put the Get my profile before the condition.

Community Support Team
Community Support Team

Re: Flow failed - Get my profile

Hi @ Maorzd23,

 

Could you please show me the entire screenshot of the flow ?

Do you want to get the email of the current user?

 

What did you type in the User (UPN) field of the “Get my profile(V1)” action?

Action “Get user profile(V1)” retrieves the profile of the current user. Required parameter for this action is user principal name or email id.


You could enter your email address in the UPN field, or you could also select a dynamic content that will return an email address for the UPN field.


Please check this documentation to get more details about the connector Office 365 Users:
https://docs.microsoft.com/en-us/connectors/office365users/

 

 

I have made a test on my side, the “Get my profile(V1)” action is removed from my Office 365 Users connector, so I use the “Get my profile(V2)” action to test.

The “Get my profile(V2)” action retrieves the profile of the current user. To get the email of the current user, you could leave the Select query field of “Get my profile(V2)” blank as screenshots below:

 3.png

 

The flow would run successfully as below:

 4.png

 

 

Regards,
Alice Zhang

DavePotts_BritE
Level: Powered On

Re: Flow failed - Get my profile

I've just hit the same problem.

 

@Maorzd23 , did you resolve your issues?

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors
Users Online
Currently online: 415 members 4,881 guests
Please welcome our newest community members: