cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
MinhPham96
Helper III
Helper III

Flow failed even though it worked: "ActionFailed. An action failed. No dependent actions succeeded. "

Hello, currently we are testing a flow that receive a JSON file from PowerApps, parse the JSON file then submit the data to D365 FO, we first tested it with 5 records and it worked fine, so we decided to do a performance test and we uploaded around 1800 records. We ran the Flow and it reported fail, but the records were all created on D365 FO. So what is the problem here ? This is our Flow format

 

MinhPham96_0-1596785799355.png

 

1 ACCEPTED SOLUTION

Accepted Solutions
Tom_Slosse
Memorable Member
Memorable Member

Hey @MinhPham96 

 

 

Could you provide more information about the error in one of the items in the Create record action?

 

Kind regards

 

Tom



If this reply has answered your question or solved your issue, please mark this question as answered.

Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up.

View solution in original post

3 REPLIES 3
Tom_Slosse
Memorable Member
Memorable Member

Hey @MinhPham96 

 

 

Could you provide more information about the error in one of the items in the Create record action?

 

Kind regards

 

Tom



If this reply has answered your question or solved your issue, please mark this question as answered.

Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up.

View solution in original post

MinhPham96
Helper III
Helper III

Ok, sorry everybody, we realized that the dataset that we used for performance test was also used before so some of the record GUID was already in D365 FO and prevents the Flow to proceed. We changed all the GUID and were able to succeed. Since the error message did not tell us there was an existing record and we compared the total wrong.  

Hey @MinhPham96 

 

 

Ok great to hear you've found the cause of the problem.

You can set your post or one of mine as a solution.

 

Kind regards

 

Tom



If this reply has answered your question or solved your issue, please mark this question as answered.

Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Users online (1,552)