cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Helper III
Helper III

Flow failed even though it worked: "ActionFailed. An action failed. No dependent actions succeeded. "

Hello, currently we are testing a flow that receive a JSON file from PowerApps, parse the JSON file then submit the data to D365 FO, we first tested it with 5 records and it worked fine, so we decided to do a performance test and we uploaded around 1800 records. We ran the Flow and it reported fail, but the records were all created on D365 FO. So what is the problem here ? This is our Flow format

 

MinhPham96_0-1596785799355.png

 

1 ACCEPTED SOLUTION

Accepted Solutions
Memorable Member
Memorable Member

Hey @MinhPham96 

 

 

Could you provide more information about the error in one of the items in the Create record action?

 

Kind regards

 

Tom



If this reply has answered your question or solved your issue, please mark this question as answered.

Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up.

View solution in original post

3 REPLIES 3
Memorable Member
Memorable Member

Hey @MinhPham96 

 

 

Could you provide more information about the error in one of the items in the Create record action?

 

Kind regards

 

Tom



If this reply has answered your question or solved your issue, please mark this question as answered.

Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up.

View solution in original post

Helper III
Helper III

Ok, sorry everybody, we realized that the dataset that we used for performance test was also used before so some of the record GUID was already in D365 FO and prevents the Flow to proceed. We changed all the GUID and were able to succeed. Since the error message did not tell us there was an existing record and we compared the total wrong.  

Hey @MinhPham96 

 

 

Ok great to hear you've found the cause of the problem.

You can set your post or one of mine as a solution.

 

Kind regards

 

Tom



If this reply has answered your question or solved your issue, please mark this question as answered.

Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Users online (11,032)