cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Flow failing with error-Common invalid characters include the following: # % * : < > ? in sharepoint

My flow is failing with the error:

Flow goes this , Docusign --> Sharepoint.

 

 

"error": {
"code": 502,
"source": "flow-apim-europe-001-northeurope-01.azure-apim.net",
"clientRequestId": "2f666bd3-1154-4169-972f-e6f338208927",
"message": "BadGateway",
"innerError": {
"status": 502,
"message": "The file or folder name \"Shared Documents/2019/Belgium/Contract 2019 for_BE_AA BTS N.V.\" contains invalid characters. Please use a different name. Common invalid characters include the following: # % * : < > ? / |\r\nclientRequestId: 2f666bd3-1154-4169-972f-e6f338208927\r\nserviceRequestId: 8d5ab39e-c0bf-0000-43d4-7ccb6b1bce64;8d5ab39e-90c5-0000-43d4-7aae60d97a79",
"source": "https://baplc.sharepoint.com/sites/AgencyContracts/BA%20Contracts/_api/web/GetFolderByServerRelative....'",
"errors": [
"-2130575245",
"Microsoft.SharePoint.SPException"
]
}
}
}

 

 

This is the subject of the documents---Contract 2019 for_BE_AA BTS N.V. 

On debugging i could see , if the subject contains dot or fullstop , its failing with above error.

 

Can you someone provide any lead on this or  has faced this similar issue .

2 REPLIES 2
Community Support Team
Community Support Team

Re: Flow failing with error-Common invalid characters include the following: # % * : < > ? in

Hi @Anonymous,

 

Could you share a screenshot of your Flow configuration?

I am not sure about your specific configuration, so I can't reproduce similar errors.

However, from the error message and your debugging results, the only solution seems to be to eliminate invalid characters in the file name or folder name.

I am afraid you need to do these pre-work, please make sure that the file name or folder name does not contain invalid characters.

Please take a try and see if it still exists.

 

Best Regards,

Barry

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Anonymous
Not applicable

Re: Flow failing with error-Common invalid characters include the following: # % * : < > ? in

Hi Bary , Team ,

 

Thanks for the response , Below are the screens of my flow configuration.

 

 

Flow.PNGOverall flowflow 2.PNGConditions

 

As you could see if the subject contains particular string format -it should get saved to my sharepoint.

But if the subject contains particular string and if it has Fullstop or dot ( I am sure fullstop is not a invalid character ), the flow is failing with the above error.

 

Flow goes this way --> Docusign to sharepoint folders.

Business- If envelope conditions changes it should go through the sharepoint folders.

 

 

Eliminating the fullstop or dot from the subject name is not advisible from our end as it has business needs.

Can you please debug from your end , any help is much appreciated .

 

Please let me know if you need further details.

 

Thanks,

Chaitanya A

Helpful resources

Announcements
firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors (Last 30 Days)
Users online (5,057)