cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper II
Helper II

Flow is not getting triggered: from Microsoft Forms

Hi All,

 

I have multiple flows that are working fine. But since yesterday, when i create a new flow (copy an exisitng one), it fails to run when the action happens. This particular one i am trying right now is

- when a new response is submitted on MS form

- run the flow

 

Since its not running even once i cant manually run the flow either. Can someone plese help how i can debug this issue? Also is htere a known issue going on that is causing this problem?

 

Thanks,

suma

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Support
Community Support

Re: Flow is not getting triggered: from Microsoft Forms

Hi @sumak@chawkins@gdabate, and @ScottShearer,

 

Does the issue still exist on your side?

 

I have made a test on my side and don't have the issue that you mentioned. I have created a new flow with trigger "When a new response is submitted", and the flow would works fine when a new response to a form is submitted.

 

I guess the problem is solved by microsoft product team, please make a test again on your side and let me know if the issue still exists.

 

 

Best regards,

Alice

View solution in original post

20 REPLIES 20
Highlighted
Regular Visitor

Re: Flow is not getting triggered: from Microsoft Forms

We are seeing teh same behavior.  Forms triggering Flows that were created weeks ago seem to continue to work, but when new Flows, linked to Forms do not appear to trigger.  All connections (which are shared among the old and new flows) were tested and seem to be functioning wiht the old flows, but will not trigger when the Form is submitted attached to the new Flow.  This problem seems to have been recently introduced.

Highlighted
Super User III
Super User III

Re: Flow is not getting triggered: from Microsoft Forms

@sumak and @gdabate:

 

I just ran a quick test with a new Form and a new Flow and the trigger won't fire.

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott
Highlighted
New Member

Re: Flow is not getting triggered: from Microsoft Forms

I'm having the same problem. Do we know if this is a global issue with Microsoft? 

 

Highlighted
Helper II
Helper II

Re: Flow is not getting triggered: from Microsoft Forms

Hi All,

 

Is there a way to get some help on this issue as this is stopping us from testing multiple flows? Is there a direct supprt email/contact for this kind of issues to get help on?

 

Thanks,

suma

Highlighted
Community Support
Community Support

Re: Flow is not getting triggered: from Microsoft Forms

Hi @sumak@chawkins@gdabate, and @ScottShearer,

 

Does the issue still exist on your side?

 

I have made a test on my side and don't have the issue that you mentioned. I have created a new flow with trigger "When a new response is submitted", and the flow would works fine when a new response to a form is submitted.

 

I guess the problem is solved by microsoft product team, please make a test again on your side and let me know if the issue still exists.

 

 

Best regards,

Alice

View solution in original post

Highlighted
Anonymous
Not applicable

Re: Flow is not getting triggered: from Microsoft Forms

Hi All,

 

I actually had the same problem too.

But, I had tested my flow now, and it works perfectly fine.

 

Good day and merry X-Mas everyone! 🙂

Highlighted
Helper II
Helper II

Re: Flow is not getting triggered: from Microsoft Forms

Yes, the problem is still there. I just tested the form and the flow still does not get triggered.

 

Thanks,

suma

Highlighted
Helper II
Helper II

Re: Flow is not getting triggered: from Microsoft Forms

There seem to be some serious issue here. Now the old flow that used to work also has stopped working. (this flow had major workflow associated with critical functionality and has caused major issues for the team!). Is there someone that we can directly work with to resolve this issue? 

 

Thanks.

Highlighted
Regular Visitor

Re: Flow is not getting triggered: from Microsoft Forms

I tested again this morning.  Same scenario.  Old flows (created several weeks ago) are getting triggered fine by the Form to which they are linked.  New Flows, linked to a Form that simply triggers an Azure Stored Procedure, is not getting triggered.  There is no Run Hisotry at all for the Flow, indiciating that it is not even attempting to run the SP.  The Form is clearly linked to the Flow by sellecting it in the When a new response is submitted  combo box for the Flow object, but it is not linking the Flow to the Form properly.  We have compared functioning and non-functioning Forms/Flows side by side and they appear identical. 

 

This will impact our corporate beginning of year processes and we have to look for an alternative solution.

Highlighted
Regular Visitor

Re: Flow is not getting triggered: from Microsoft Forms

Ok, my team has isolated the bug in the creation of Flows and we are working around it.  It seems as we created a Flow, and link it to the Form, we were using the Form name that was selected in the combo box to name the Flow (i.e., changing the 'Untitled' in the upper left of the window to the Form Name, after the form had been selected).  We then go on and complete the rest of the flow including the execution of an Azure Stored Procedure.  The Flow would then fail to Trigger off the filing of the corresponding Form.  It appears someone failed Programming 101 and has tied the Flow/Form trigger to the Flow Name instead of using a GUID or equivalent. 

 

The problem is worked around by setting the Flow Name to the Form Name (or whatever name you choose) BEFORE selecting the Form. Once we instituted this procedure, we were able to add all our new, 2019 Employee HR Forms.  We wasted an estimated 12 hours trying to figure this issue out.  It can be easily recreated, and I suspect most others who have reported this problem have been editing the Flow Name during, or after it was initially created. 

Highlighted
Regular Visitor

Re: Flow is not getting triggered: from Microsoft Forms

Hi community support team,

 

Is there still being worked on a solution for this. Great that there is a workaround, but it basically means not being able to copy (export/ import) existing flows that start with a form trigger. Which causes extra work. Would be great if the actual problem can be fixed.

 

Thanks!

Highlighted
Anonymous
Not applicable

Re: Flow is not getting triggered: from Microsoft Forms

I just have same issue today, Flow isn't triggered when Forms response submitted. When I'm checking, all dynamic response doesn't appears what it supposed to be. Looks like the connection between Flow and Forms have issue.
Highlighted
Frequent Visitor

Re: Flow is not getting triggered: from Microsoft Forms

Hi@v-yuazh-msft ,

 

I have the same issue. Any idea?

 

form trigger error.JPGform trigger error3.JPGform trigger error2.JPG

Highlighted
Anonymous
Not applicable

Re: Flow is not getting triggered: from Microsoft Forms

The same issue here. I tried old and new Flows and Forms in multiple tenancies. No triggering.
However, I can see that some Flows were triggering 4 days ago.

Highlighted
Frequent Visitor

Re: Flow is not getting triggered: from Microsoft Forms

Hello

Has this problem coming back again? I have a similar flow which works fine until today. For unknown reason, the flow now won't be triggered as result of form submission, just like nothing happened.

 

Any ideas?

Highlighted
Anonymous
Not applicable

Re: Flow is not getting triggered: from Microsoft Forms

This thread informing that Flow triggered with the delay >6 hours after Form submission.

https://powerusers.microsoft.com/t5/Using-Flows/Forms-trigger-not-detecting-changes-to-the-form/td-p...

Hopefully will be resolved soon.

Highlighted
Regular Visitor

Re: Flow is not getting triggered: from Microsoft Forms

I am facing the same issue which occurred today

It seems that flow is no longer picking up the trigger action of "When a new response is submitted" thus, the flow is never triggered.

 

 

Highlighted
Frequent Visitor

Re: Flow is not getting triggered: from Microsoft Forms

Same issue here. Flow triggered by MS Forms is not firing. Tested yesterday at 4pm and it finally ran at 3am this morning...

Any updates on this?

Highlighted
Frequent Visitor

Re: Flow is not getting triggered: from Microsoft Forms

Same issue here!! What is going on?!?! I have a presentation on Thursday and if it does not work I am not going to be happy~!!!!!!

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Tech Marathon

Maratón de Soluciones de Negocio Microsoft

Una semana de contenido con +100 sesiones educativas, consultorios, +10 workshops Premium, Hackaton, EXPO, Networking Hall y mucho más!

Users online (6,577)