cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Regular Visitor

Flow with a checking condition a true/false value which always returns false

I have a requirement on Microsoft Flow. Depending upon my requirement, I have a SharePoint List and in that list, I have one Yes/No field column.

When I am trying to put this Yes/No field Column in flow Condition is equal to true/false or 0/1, Always the condition returns as "no" even if it is true. How can I resolve this issue?

Below is the flow screenshot: 

 

flow error.png

8 REPLIES 8
Highlighted
Advocate III
Advocate III

I don't know if it's related, but I have a flow I'm working on, and last week, my conditions where working perfectly, but now they seem to return false (no) and I can't figure out why. At this moment I'm still trying to figure out what's wrong.

This should return true, if the three fields are cleared, but it always returns false, even if they are cleared.

image.png

 

I can get it to return true (yes), if I change "is equal to" to "is not equal to".

As I said, this was working last week.

Highlighted
Community Support
Community Support

Hi @Preetish ,

 

Could you provide more details about the field you mentioned?

Do you have any special treatment for it?

Basically the return value of Yes/No field is true and false.

I did a test on my side. If Yes is selected in the field, the result of Condition judgment will be true.

Image reference:

21.PNG

You could try adding a Compose action on Condition to output the return value of the current field to see if this field selects Yes or No.

22.PNG

Please take a try and see if issue still exists.

If the problem persists, please provide Flow run history, including the results of Compose output so that we can analyze the problem.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted

I got the same problem. Adding "compose" fixed it 🙂

Highlighted

I have the same issue.  I tried adding compose to the condition, which returns the Yes/True as it should, but it still prompts false. 

@v-bacao-msft 

Highlighted
Highlighted

/

Highlighted

The op's screenshot shows the word "true" being manually added which won't work. Has to be an expression you can look up. Not very intuitive and poorly documented as usual.

Untitled.png

Highlighted
Helper I
Helper I

As the blog post that @acewmu points to, and the screenshot that @webbrewer shows, you have to add the 'true' part via an expression:

 

expression true.png

One thing to add is that (for me at least) when you type true in the expression input box and click the autocompleted 'true' (in blue text with the little icon next to it on the left as shown in the image above), then click OK, you might get an error saying "The expression is invalid". IGNORE THAT! It's an annoying little bug. Simply click OK to close the error dialog box and then click OK underneath the expression input box and, this time, the "error" will not appear and true will appear in the condition box in a pink box with the 'fx' icon next to it on the left (as shown in the image above)

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Users online (16,358)