cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Advocate II
Advocate II

Flows now taking up to 18 hours to complete when they were taking minutes

One of our flows has started taking hours to complete, when it used to take a few minutes. This started happening yesterday. There are a few hundred instances of the flow in the running state. They seem to eventually complete but it can take from 1 to 18 hours. 

 

They are not stuck on a specific action, some show they are stuck on a variable assignment, others on a switch.

 

Anyone else seeing anything similar?

1 ACCEPTED SOLUTION

Accepted Solutions

It turns out that this was self-inflicted. One of our flows was triggering itself, causing it to kick off thousands of runs. Once we fixed the issue, the performance returned to normal

View solution in original post

2 REPLIES 2
Community Support
Community Support

Hi @ivan_wilson

 

Does your flow issue still exists?

Could you please share a screenshot of the configuration of your flows which would take up to 18 hours to complete?

 

Please share more details so we would try to provide a proper workaround for you.

 

Best regards,

Alice

It turns out that this was self-inflicted. One of our flows was triggering itself, causing it to kick off thousands of runs. Once we fixed the issue, the performance returned to normal

View solution in original post

Helpful resources

Announcements
Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Users online (77,343)