cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ivan_wilson
Advocate II
Advocate II

Flows now taking up to 18 hours to complete when they were taking minutes

One of our flows has started taking hours to complete, when it used to take a few minutes. This started happening yesterday. There are a few hundred instances of the flow in the running state. They seem to eventually complete but it can take from 1 to 18 hours. 

 

They are not stuck on a specific action, some show they are stuck on a variable assignment, others on a switch.

 

Anyone else seeing anything similar?

1 ACCEPTED SOLUTION

Accepted Solutions

It turns out that this was self-inflicted. One of our flows was triggering itself, causing it to kick off thousands of runs. Once we fixed the issue, the performance returned to normal

View solution in original post

2 REPLIES 2
v-yuazh-msft
Community Support
Community Support

Hi @ivan_wilson

 

Does your flow issue still exists?

Could you please share a screenshot of the configuration of your flows which would take up to 18 hours to complete?

 

Please share more details so we would try to provide a proper workaround for you.

 

Best regards,

Alice

It turns out that this was self-inflicted. One of our flows was triggering itself, causing it to kick off thousands of runs. Once we fixed the issue, the performance returned to normal

Helpful resources

Announcements
MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Power automate tips 768x460 v2.png

Restore a Deleted Flow

Did you know that you could restore a deleted flow? Check out this helpful article.

Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

Users online (1,841)