cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Flows stop triggering unexpectedly Bad gateway 502?

Hi, I've had a number of flows stop working all of a sudden with little information on what is at fault. The flows have been working fine and were not modified aroudn the time they stopped working. The only nugget to go off is the error 'bad gateweay 502' which is reported in a some of the recent failed runs.

 

I'm unable to trigger the flow (sharepoint new item is created or modified) so i'm stumped as to why it is not triggering. I've created a simple flow in the same account with the same trigger, that works the first time then doesnt work any more...

 

I've tried copying the flow to another account but that doesnt work more than once either!

 

I've tried copying the flow and deleting the original (because i was concerned there were quite a few instances of the flow running) but that didnt work either.

 

Really at a loss as to what is wrong and this is having a significant impact on our operations. if anyone has any pointers or guidance i'd appreciate hearing them.

 

The actions contained in the flow are:

Sharepoint update item

Sharepoint get items

Outlook send email

Outlook send email with options

 

Thanks,

Eddie

56 REPLIES 56

I am seeing this same error with the message "There's a problem with the flow's trigger".  However, I'm getting "Succeeded" and I know the flow is running successfully.  

 

My trigger is when a new item is created on a SharePoint list. 

Any ideas how to fix this?  

 

{
"error": {
"code": 502,
"message": "Unable to connect to the remote server",
"source": "flow-apim-msmanaged-na-centralus-01.azure-apim.net",
"path": "forward-request",
"clientRequestId": "12301678-3dd7-45d6-a435-60c889ad420a"
}
}
 
Thank you. 
RayConsella
Advocate I
Advocate I

My flow is triggered when a file is created or updated (properties only) and ran successfully 40 times over the past month including 8 times yesterday.  Now today I get a bad gateway error??  This is not my design, this is not something I changed, and I'm sure this goes for the rest of you. This is just Microsoft being cheap and lazy and not putting the proper resources behind what should be a great product, but is far from it because of it's incredibly low reliability.  The only thing any of us can do is do be the squeaky wheel.  Log ticket after ticket after ticket, one for each flow that fails, one for each time it fails.  They're too big to notice unless they get literally thousands of tickets.  Logging my ticket now....

Anonymous
Not applicable

Hi,

 

I am also getting this error on a create table.  I have four create tables and it is just the same one no matter where in the flow I place it. Cant help think it is not gateway but something in the flow itself. Any way to get more detailed logs from Power Automate?

 

Ta

 

Mark

{
"error": {
"code": 502,
"source": "europe-002.azure-apim.net",
"clientRequestId": "ec454e7e-e96d-425e-a1e5-3b344c065f8a",
"message": "BadGateway",
"innerError": {
"status": 502,
"message": "Graph API is currently unavailable.\r\nclientRequestId: ec454e7e-e96d-425e-a1e5-3b344c065f8a\r\nserviceRequestId: e19c7ae2-6290-4ca7-9b03-df3c463bc176",
"error": {
"message": "Graph API is currently unavailable."
},
"source": "excelonline-we.azconn-we.p.azurewebsites.net"
}
}
}

 

 

 

gjeh
Responsive Resident
Responsive Resident

which is the solution

drawser
Helper I
Helper I

Same issue here,

my flow fails at the crate table step with bad gateway.

The table has formulas in it.

It has been working fine for months but started failing about two weeks ago.

 

Any update on this would be much welcome.

I found the solution to my problem.

The file in which I create a table comes from an email attachment, the file had been getting a data range the spanned outside the specified data range in the flow for create a table. I simply expanded the range and now it's working for me.

 

Slopez
Frequent Visitor

Tengo el mismo problema, todos mis flujos con Excel dejaron de funcionar y habían funcionado bien durante meses. Solo abrir y cerrar el archivo antes de que la ejecución se ejecute correctamente, pero es una tarea programada que se ejecuta todos los días, no es factible abrir los archivos a diario {"error": {"code": 502, "source": "flow- apim-europe-001-westeurope-01.azure-apim.net "," clientRequestId ":" dfd8e1c7-ef4a-4925-85fb-b501f39bd466 "," message ":" BadGateway "," innerError ": {" status ": 502, "message": "Lo sentimos, se ha producido un error en la relación con este archivo. \ R \ nclientRequestId: dfd8e1c7-ef4a-4925-85fb-b501f39bd466 \ r \ nserviceRequestId: 016ad246-3991-48de-8215-31fa0a4dd" , "error": {"message": "Lo sentimos,

CW
Post Patron
Post Patron

Yes I constantly have this same issue. You create a flow, it works several times, you go away for a while then all of a sudden you receive these emails: your flow has failed and has been turned off. 

NOTHING WAS CHANGED!!!!!!!!!!!!!!!!!! SAME ACCOUNT(S). What gives with this nonsense?

I'm really starting to think it was an error to have started down this flow rabbit hole.

Exactly!!!!!!!!!!!!!! It's been working fine all this time now all of a sudden....................................ummmmm...............(flow speaking) I don't feel like flowing today. What cryptic and useless message can I provide???? Hmm Ya, that's the ticket. Ya ya: It's, it's a bad gateway, AND and and, your  account is, umm it's wrong. 

 

This about sums up our reaction to this constant behavior. This behavior is the ONLY consistent behavior with Microsoft stuff.

Broosie
Regular Visitor

This thread has been going on for years! It is now 2021!!! I am recently stuck on this error, too, and was hoping to find a little more positive news than this... what a pain...

MartinaHawkins
Frequent Visitor

Anyone got any update on this issue?

Hi Martina. Not on my end but it resolved on its own. Who thought software would be prone to moon phases.

Try saving the flow as another name, rebuilding it, testing at each stage.

I too have found some MSFT tech suddenly stop working simply because it's a new day.

 

Hope this offers you some solace.

vargasjo
Frequent Visitor

Hello, for those having this issue using excel connector, you can try moving your excel files from one drive to  sharepoint, in my case was only 2 files, after this it all worked ok again, maybe was some kind of limitation on my one drive, or some locked state of the files.

carudev
Helper II
Helper II

I'm having the same mistake guys, did you manage to solve it?

 

carudev_0-1619708304687.png

 

 

 
  "error": {
    "code"502,
    "source""flow-apim-msmanaged-na-northcentralus-01.azure-apim.net",
    "clientRequestId""4090f3ba-cfce-4d7b-a8bf-19e0bebe7bbc",
    "message""BadGateway",
    "innerError": {
      "status"502,
 

I WONDER IF THIS WILL WORK FOR THE FORTH ATTEMPT. 

 

I fixed it and other very very irritating issues ( such as me attempting to respond four times and respond to their feedback WHIL logged in) by not using the stuff anymore.

Wayyyy to many irritating issues given it's 2021. 

 

EDIT: Wow it only took five attempts to make it stick. Terrible. carudev run for the hills.

Harris0261
Frequent Visitor

It is 11/10/2021 and I am experiencing this issue. Is there any solution for this or we just have to wait?

Wait if you can, I couldn't and creating a new Excel file/template for me was the only solution to get it working on the day. For some reason, my flow wouldn't work days after I started getting it. That was a long time ago and I haven't had any issues since then. Seems like it's a random "thing".

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Users online (2,803)