cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
cow
Level: Powered On

Forms Pro issue when triggered via Flow in Dynamics 365

Hey Everyone!

 

I'm currently working at replacing our VOC surveys with Forms Pro and running into an issue with linking the survey and response from Forms Pro to the Lead entity.

 

For example... One of the current VOC survey's is sent to a lead via a Flow that triggers an email template (in D365) containing a link to the VOC survey.  The Lead fills out the survey and the sales agent is notified via email that the survey has been completed and it's then attached to the Lead record and visible in the timeline in D365. 

 

I've recreated the VOC survey in Forms Pro and if I send it from the Forms Pro page via email the survey and response gets attached to that Lead record.  Perfect!  Though thats not an ideal process for our team.  So I've created a Flow in D365 (screenshot attached) that our team can send to a Lead through D365.  The Flow works and the Lead receives the survey.  The issue is that after completing the survey, the response isn't attached to the Lead entity.  Instead it seems to create a Contact record and attach the survey to that record.  We'd prefer to not create a Contact prior to a Lead being qualified.

 

Is there a way to make Forms Pro act like VOC in how it sends to a Lead and then attaches to that Lead without creating a Contact?

 

Thank you!

2 REPLIES 2
Community Support Team
Community Support Team

Re: Forms Pro issue when triggered via Flow in Dynamics 365

Hi @cow,

 

Can you re-upload the screenshot of Flow in D365? It seems that the screenshot you uploaded before didn't work, you can click the button to insert photos:Annotation 2019-11-14 142551.png

 

Are the Lead and Contact custom entities you created in Dynamic 365?

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

cow
Level: Powered On

Re: Forms Pro issue when triggered via Flow in Dynamics 365

HI @v-litu-msft ,

 

Thank you for taking a look.  Screenshot attached. 

 

Screen Shot 2019-11-12 at 4.25.51 PM.png

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors (Last 30 Days)
Users online (5,606)